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How to Create New Image File

Topic

How to create a new image file in GIMP?

Explanation

This is the initial step in GIMP which guides you to create a new image file with different height and 
width properties.
Steps to Follow:
- Start GIMP.
- Click File -> New or else just press Ctrl+N.

- A box named Create a New Image gets displayed.

- The box exhibits the default image size. Alter the size either manually or through the up and down 
arrows.
- Set the type/nature of picture file size. Just click the pixels. A list drops down from where you can 
choose the category.
- If you desire to have a pre defined picture file size, then click the Template. A list of items will be 
displayed in the list box. Choose one item from the list as per your need.
- The Advanced Options list you additional features like "Resolution, Color space, Fill with and 
Comment". Apply these options if you need them.
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- Then set the features and finally click the Ok button in the create a new image box.

- Now the new file has been created. A sample new file created has been shown below.Hscripts.com



How to Create a New File from Clipboard

Topic

How to create a new image file from clipboard in GIMP?

Explanation

This method allows you to generate a file from various sources.
Steps to Follow:
- Launch GIMP.
- Click File -> Create and the options get displayed.

- The options From Clipboard, Scanner or Camera, Screenshot permit you to create a file from 
these sources.
- The Clipboard option lets you to paste the image content from the clipboard. Note that you can 
paste the content only if it is available in clipboard.
- The Scanner/Camera option allows you to create file through a scanner or camera. This is a 
method of creating file from an outside source. Either the Scanner or Camera should be connected 
to your computer system to create the file.
- A box named "Select Source" appears. Click the available items in it(items will be displayed only if 
a scanner/camera is connected to computer) and create a file. View the below image.
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- The Screen Shot is an option to create file by taking screenshots of the items seen in screen. 
Either single window or whole window can be taken as a screenshot.
- Click File-> Create-> Screen Shot to take screenshot of the window.
- A box named WinSnap displays.

- Set the options in the box and click the button Grab to get the screen shot of the window.
- The rest of the options like Buttons, Logos, Patterns, webpage Themes are used to obtain 
logos, patterns, pre defined shapes and themes from webpages.
- Simply set the features and click the "Ok" button to get the new file.
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How to Open a File

Topic

How to open a file in GIMP?

Explanation

This page explains you as to how to open a new file.
There are four ways to open a file and this is the first method.
The rest of the three methods are:
1] To open as layers -> Open As Layers
2] To open file from location -> Open File From Location
3] To open a recent file -> Open Recent Document
Method 1:
Follow below steps to launch a file:
- Launch GIMP.
- Click File -> Open or else just press Ctrl+O to Open a file.

- A box displays with name Open Image.
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- The folders are displayed at the left hand side of the box. Open it and select an image file to open.
- When a file is selected, user can view the Preview of the image file at the right hand side of the 
box.

- To search a file manually, just click the Pencil icon in the "Open Image" box and type the location 
of a file in the "Location" column and then open the image file.

- Finally, save the file through File -> Save and click the "Save" button.
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How to Open a File as Layers

Topic

How to open a file as layers in GIMP?

Explanation

This page will explain you how to open a file as layers using GIMP.
Method 2:
Steps to Follow:
- Launch GIMP.
- Click File -> Open as Layers or else just press Ctrl+Alt+O to open a file.

- Then a box displays with name Open Image.Hscripts.com
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- Choose any image file and click the Open button in the "Open Image".
- The image file will be opened with layers i.e. the layers will be added to currently opened image. 
(View the below image)

- Apply changes in the file and then save the file through "File -> Save" and click "Save" button.
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Open a file from a Location

Topic

How to open a file from a location in GIMP?

Explanation

This page explains you how to open a file from location.
The Open Location option enables you to use images from Online.
Note that you must have the Internet Connection to launch an image, in case you use this method.
Method 3:
Steps to Follow:
- Open GIMP.
- To launch a new image file, click File -> Open Location or else open GIMP and then press Alt+F
and L button.

- A box displays with name "Open Location".

- Now enter the URL address of the image in the "Enter Location" column.
- Then click Open button.

- Just wait until the image gets downloaded. (View the marked portion in the below image)
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- The image will be displayed on the screen.

- Complete your work and finally save the file by clicking "File -> Save" and again clicking the 
"Save" button.
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How to Open a Recent Document from History

Topic

How to open a recent document from history in GIMP?

Explanation

This page explains you how to open a recently opened document from history.
It enables the user to open an image which was closed recently.
Method 4:
Steps to Follow:
- Open GIMP.
- To launch a new image file, click File -> Open Recent or else press "Alt+F" and "R".

- The "open recent" menu displays the list of image files which were opened and closed recently.

- Select the image file, which you like to open now.
- The user can also clear the Document History if he/she wishes to.
- Click File -> Open Recent -> Document History to open the document history box.
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- Simply click the "brush" icon in the box to clear all the images. (View the lower portion of the 
above image file)
- Then a box appears with the name Clear Document History.
- Click the Clear button in the box.

- Now the entire images will be cleared. (View the below image)

- User can also delete the images one by one in the document history box.
- Just click the "-" symbol in the document history box and delete the files one by one.
- Finally save the file by just clicking "File -> Save". A box opens up. Click the "Save" button.
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How to Cut and Paste Pictures / Image

Topic

How to cut and paste pictures / images into layers in GIMP?

Explanation

This page explains you how to cut and paste an image or pictures into multiple layers in GIMP.
Steps to Follow:
- Open GIMP.
- Click File -> Open or else just press Ctrl+O, then choose a file and now click Ok button.

- Click Select->All or else press Ctrl+A which selects the whole image.
- If you want a part of the image to be selected, choose "Rectangle Select Tool or Ellipse Select 
Tool or Free Select Tool" from the toolbox. Then select the portion which you want to cut or copy. 
(View the below image)

- Click Edit->Cut or press "Ctrl+x" to cut the selected portion of the image.

- The selected portion in the image gets sliced. You may may use the sliced part to paste in a new 
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file or even in a new layer.
The below portion provides you the information regarding the paste methods in GIMP.
- Open GIMP and launch a new image file.
- Now select a portion in the image.
- Then choose either "Cut or Copy" option, to cut or copy the image.
- Click Edit -> Paste.

- Then the image gets pasted.
- The Paste Into option pastes the image over the existing image. The pasted image can be moved.
- The difference between the "Paste & Paste Into" option is that the paste option simply pastes the 
image and it cannot be moved. But the "paste into" option allows the user to move the pasted 
portion.
- Then click Edit -> Paste as.

The Paste as option provides four more options, which allows the user to paste the image in various 
styles. The options are "New Image, New Layer, New Brush, New Pattern".
- Select any one of the options. For e.g. New Image from "Paste as". This will automatically paste 
the image in a new window.

Hscripts.com



- The New Image & New Layer option do not require any additional process. Just click it and the 
image gets pasted.
- Finally click "File -> Save" to save the file.
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How to Copy and Paste Pictures / Image

Topic

How to copy and paste pictures / images into layers in GIMP?

Explanation

This page explains you how to copy and paste an image or pictures into multiple layers in GIMP.
Steps to Follow:
- Launch GIMP.
- Click File -> Open or else press Ctrl+O to open a file, then choose a file and now click Ok button.

- In case you want the entire image to get copied, click Select->All or else simply press Ctrl+A.
- Suppose you want to select a certain portion of an image, use the "Rectangle Selection Tool or 
Ellipse Selection Tool or Free Selection Tool" of the Selection Tools from the toolbox.

- The Paste Into option pastes the image over the existing image. In this option, the pasted image 
can be moved to view the existing image. However the "Paste" option simply pastes the image and 
it cannot be moved.
- Another option named Paste as facilitates four more options which allows the user to paste the 
image in various styles like "New Image, New Layer, New Brush, New Pattern".
- Select any one of the options - for e.g. New Image. This automatically pastes the image in a new 
window and you can view it.
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- The New Image and New Layer option do not require any additional process. Just click it and the 
image gets pasted.
- The New Brush and New Pattern demand an extra action i.e. you need to set the brush/pattern 
name and file name then click "Ok" button to see the image.
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How to Undo, Clear an Image

Topic

How to undo, clear an image in GIMP?

Explanation

This page explains you how to undo or clear an image in GIMP.
Steps to Follow:
To Undo->
- Open GIMP.
- Commence a file by choosing "File -> Open", pick a file and click "Ok" button.

- After making changes to the image, suppose you wish to have the old image back, then click "Edit-
>Undo" or else press "Ctrl+Z".
- Click "Edit->Fill with FG Color" to apply Foreground Color to an image. (view the below image)

- The default foreground color is "Black". So black is filled on the image. (View the above image)
- Now click Edit->Undo or else press Ctrl+Z to undo.

- The undo process is completed and the changes made on the image are removed.
To Clear->
- Open GIMP and launch a file by clicking the "File -> Open" then choose a file and click "Ok" button.
- First click "Select->All" or press "Ctrl+A" to select the whole image.
- Incase you want a part of the image to be removed, choose any one of the tools like "Rectangle 
Select Tool/ Ellipse Select Tool/ Free Select Tool" from the toolbox as per your convenience and 
select the portion in the image.
- Make any modifications in the image or else apply color to the image.
- Now click Edit->Clear or else simply press the Delete button to clear the whole image.
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- Finally click "File -> Save" to save the file.
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How to Fill Foreground Color to an Image

Topic

How to fill the foreground color of an image in GIMP?

Explanation

The main aspect of the Foreground Color is that it fills the image with the default foreground color.
User can select any portion of the image and fill it with foreground color.
Steps to Follow:
- Open GIMP.
- Launch a new image file.
- Select a portion of an image, where you want to fill the color using any available Selection tools in 
toolbox.
- In the below image, left portion of the image has been selected using the Rectangle Selection Tool.

- Now click Edit->Fill with FG color or else press "Alt+E and F" button to load color in foreground of 
the image and wait until the process gets completed.
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- The default "Foreground Color" is set as Red. So when FG color is applied, the red color will be 
filled on the image.
- Now the image is filled with the Foreground Color (View the below image).

- Finally click "File -> Save" to save the file.
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How to Fill Background Color to an Image

Topic

How to fill background color in GIMP?

Explanation

The Background Color fills the image with the default background color.
User can pick a portion of the image and fill it with the background color.
Steps to Follow:
- Open GIMP.
- Launch a new image file.
- To fill the color, use the Selection tools in toolbox to select any portion of an image (or the entire 
image).
- To fill the background color, click Edit->Fill with BG color click or press "Alt+E and G button".

- In the below image, the entire portion (other than the image) is selected to fill the background color.
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- Now the selected portion of the image is filled with the Background Color.
- The default "Background Color" is set as Green. So while applying BG color, the selected portion 
will be filled with Green color.
- In the below image, only the portion other than image have been selected using "Rectangle 
Selection Tool". So, the color is filled other than the image.
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How to Add Pattern to Image

Topic

How to add patterns to an image in GIMP?

Explanation

* The Pattern tool is used to fill an image with a variety of shapes or designs.
* It is feasible to apply different kinds of pattern effects can be selected and applied to an image.
Steps to Follow
- Open GIMP.
- Launch a new image file.
- To insert a pattern on an image, the user needs to select a portion of the image. User can utilize 
any Selection tools available in toolbox to select.
- Now click Edit->Fill with Pattern or else press Alt+E and A button to use patterns.

- In the below image, the portion other than the image has been selected to apply the pattern.
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- Note the pattern applied on the below image.

- To apply different kinds of "Patterns", just click the Pattern Icon in the toolbox.

- Pick any one of the patterns and apply it for the image.
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- Finally click "File -> Save" the file.
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How to Add Stroke / Borders on Selection

Topic

How to add stroke lines or borders to an image selection in GIMP?

Explanation

Stroke Selection is an act of striking the selected portion of an image.
Steps to Follow:
- Open GIMP.
- Click File -> Open and then choose a file. Click Ok button.

- Now select a portion of the image using selection tool.
- Click Edit->Stroke Selection or else you can access it through clicking Select->Selection Editor.
- Then a box named Stroke Selection appears.

Normally, you can strike the image either by applying Stroke Line or with the Paint Tool option.
Stroke line:
- Click the radio button named Stroke line and then set the Line width.
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- Pick either Solid color/Pattern as you require.
- When you click the Line Style, a few more options appear. Set the "Cap style, Join style, Miter 
limit, Dash pattern and Dash preset" as per your need and finally choose Antialiasing option if you 
want.
- The Antialiasing option smoothens the curved strokes or strokes drawn over an image. Use this 
option to soften the strokes drawn over an image.

- Finally, the click Stroke button.
- Wait until the image gets processed and then you can find the stroke on image. (View the below 
image)

* To gather more information related to stroke selection, just use this Stroke an image with Paint 
Tool link.
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Stroke an image with Paint Tool

Topic

How to add stroke lines or borders to an image selection in GIMP?

Explanation

* Stroke with a paint tool option enables the user to strike an image with the 11 paint tools provided 
in the Brush Tools.
* The tools(view the last image of this page) of the brush tools can be used to strike an image.
* The tools available with this option can also be termed as "Paint Tools".
Steps to Follow:
- Open GIMP.
- Launch a new image file and select a portion of it.
- Click Edit->Stroke Selection or else you can access it through clicking the Select->Selection Editor.
- Then a box named Stroke Selection appears.
- Click the radio button named "Stroke with a paint tool" in the Stroke Selection box.

- Select any one of the options available from the paint tool, for e.g. Eraser and also choose 
Emulate brush dynamics if you wish.
- Emulate brush dynamics allows the user to combine the different brush parameters i.e. the three 
input dynamics "pressure, velocity and random" to enhance the level and appearance of an image.
- Then click the Stroke button and then see the erase featured stroke on the image.
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- Apply the available options under the paint tool (below listed items), in order to have best stroke 
for your image.

- Finally click "File -> Save" the file.
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Keyboard Shortcuts

Topic

GIMP Keyboard Shortcuts

Explanation

Keyboard Shortcuts:
Gimp allows you to edit, configure or apply new keyboard shortcuts. So you may either create a 
new shortcut for a command or else alter an existing available shortcut.

Edit Keyboard Shortcuts

Configure Keyboard Shortcuts
Apply New Shortcuts
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How to Configure New Keyboard Shortcuts

Topic

How to configure or create new keyboard shortcuts in GIMP?

Explanation

This page explains you how to create or configure new keyboard shortcuts in GIMP.
* The tools which are accessible through the image menu will have a default keyboard short-cut.
* So you may either create a new shortcut for a command or else alter an existing available short-
cut.
Steps to Follow:
- Open GIMP.
- Then click Edit->keyboard shortcuts.

- Then a box displays with the name Configure keyboard shortcuts with options in it. Around 17 
categories are listed in the box.
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- Click the + symbol in the box to list/see the options of a particular category, for e.g. File.Hscripts.com



- Now click any shortcut, for e.g. "Revert" option under "File" menu.
- Just click the "Disabled" button, press a key of your choice and save the settings.
- Then apply the shortcut to identify whether it works or not. The same process applies for the 
predefined shortcuts too.
- View the Keyboard Short cuts, memorize and apply it while working in GIMP.
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How to Edit/Delete Keyboard Shortcuts

Topic

How to edit or delete new keyboard shortcuts in GIMP?

Explanation

This page explains how to edit or delete a keyboard shortcut in GIMP.
Steps to Follow:
Edit Keyboard Shortcut:
- Open GIMP.
- Now, click Edit->keyboard shortcuts.
- A box named Configure keyboard shortcuts  gets displayed.
- By default, there are 17 categories available in the box.

- Click the + symbol of any menu, for e.g. Edit . Now the shortcuts available under the edit gets 
displayed.

- Then click "disabled" option under the title Shortcut. Note that some menus may have shortcut by 
default. In that case, the current shortcut key will be displayed instead of disabled option.
- The disabled option changes as "New accelerator". Now click any key to assign the shortcut or to 
replace it. (For e.g. See the below image)
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Delete Keyboard Shortcut:
- To delete a shortcut, simply click the respective shortcut key and then press Backspace button.
- This will delete the shortcut key. (View the below image)

Identify Keyboard Shortcut:
- If you are unable to find a shortcut, just enter that word in the Search column of Configure 
keyboard shortcuts box for e.g. Save.
- Then a list of shortcuts related to the keyword will be displayed.

Save Keyboard Shortcut:
- Click the check box named "Save Keyboard Shortcuts on exit" to save the modifications.
- Finally, click the Close button to close the Configure keyboard shortcuts box.
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How to Create New Keyboard Shortcuts

Topic

How to create new keyboard shortcuts in GIMP?

Explanation

This page explains how to create new keyboard shortcut in GIMP.
Steps to Follow:
-> Open GIMP.
-> Click Edit -> Keyboard Shortcut.

-> A box named Configure Keyboard Shortcuts displays.
-> Now pick any one of the menus, for which you wish to create a new shortcut. For e.g. Open 
Location.
-> The open location does not have a keyboard shortcut in GIMP.

-> Now click "disabled" option under the title shortcut.
-> When it changes as "New accelerator", press the button which you like to set as the new key 
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board shortcut for open location. For e.g. Y.
-> "Y" is the shortcut key assigned for open location.

-> Now click the Close button in the configure keyboard shortcut box.
-> Now press the button Y.
-> The Open Location box gets displayed.

-> In "Open Location" box, enter the URL and click the "Open" button to open the pictures from a 
specified location in net.
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Tool Box

Topic

Tool Box in GIMP

Explanation

Introduction - Toolbox:
* The Tool box assists the user to generate/develop an image file. File or image cannot be 
manipulated without the help of these tool options.
* 33 Tools are available here to create images.
Steps to Follow:
- Launch GIMP.
- View the Toolbox in the left side of the screen.

The below portion of the toolbox displays the subsidiary options of the chosen tool in the main panel.

- Options like Save, Restore, Delete and Reset are available at the bottom portion of the toolbox.
- If you desire to make some modifications in the current tool options, then you can do it by 
Configuring it. Click the left arrow icon to "Configure the Tools".
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- User can customize the toolbox in GIMP.
* These are classified into 5 categories on the basis of their Type or Nature of their performance. 
They are
1. Selection Tools
2. Brush Tools
3. Transform Tools
4. Miscellaneous Tools
5. Color Tools
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Selection Tools

Topic

Selection tools in GIMP

Explanation

Selection tools are used to select particular regions from the active layer so that the other regions 
of the layers do not get affected..
There are a total of 7 selection tools available and each one has its own individual properties. 

- There are 7 Selection Tools listed in the Toolbox and let us see one by one.
- Rectangle -> Selects square or rectangular regions.
- Ellipse -> Selects circular or elliptical regions.
- Free -> Draws free-form selections.
- Fuzzy -> Selects continuous regions of colour.
- By Color -> Selects all instances of a colour in an image.
- Scissors -> Creates path to select shapes.
- Foreground -> Selects a region containing foreground objects.Hscripts.com
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Brush Tools

Topic

Brush tools in GIMP

Explanation

* Brush tools are also referred as the Paint Tools in GIMP.
* These tools are grouped together and they are not only limited for image layers but also for the 
entire image.

- There are about 13 Brush Tools listed in the Toolbox and let us see one by one.
- Bucket Fill -> Fills an area with a colour or pattern.
- Blend -> Fills an area with a gradient.
- Pencil -> Paints hard-edged lines; that is, the pixels are not anti-aliased.
- Paintbrush -> Paints soft- or fuzzy-edged lines; that is, the pixels are anti-aliased and/or feathered.
- Eraser -> Erases pixels from a layer.
- Airbrush -> Paint tool with variable pressure.
- Ink -> Paint tool with variable pressure.
- Clone -> Copies pixels from one part of an image to another.
- Healing -> Heals image irregularities.
- Perspective Clone -> Clones from an image source after applying perspective transformation.
- Blur -> Blurs or sharpens an image.
- Smudge -> Spreads pixels in the direction of the "push".
- Dodge/Burn -> Lightens or darkens an image's shadows, mid tones, or highlights.
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Transform Tools

Topic

Transform tools in GIMP

Explanation

Transform tools are used mainly to alter the appearance of the image or a particular element of an 
image. 

- There are over 8 Transform Tools listed in the Toolbox and let us see one by one.
- Move -> Moves layers and selections.
- Align -> Aligns or arranges layers and/or other objects.
- Crop -> Crops or clips the image.
- Rotate -> Rotates the active layer, selection or path.
- Scale -> Scales the active layer, selection or path.
- Shear -> Shifts part of an image to some other location.
- Perspective -> Changes the perspective of the active layer, selection or path.
- Flip -> Flips layers and selections.Hscripts.com
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Miscellaneous Tools

Topic

Miscellaneous tools in GIMP?

Explanation

Miscellaneous tools do not come under any group of tools.
It is used to create path, text, pick color, measure and zoom on an image.

- There are 5 Miscellaneous Tools listed in the Toolbox. Let us learn one by one.
- Path -> Creates desired shapes and it can be modified by choosing a portion in the image.
- Color Picker -> Selects the color for any image which is open on your screen.
- Zoom -> Enlarges(maximizes) the image.
- Measure -> Displays the distances and angles when the image is measured.
- Text -> Creates text in the selected portion of the image.
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How to Use Color Tools

Topic

What are the types of color tools in GIMP?

How to use color tools in GIMP?

Explanation

This page explains how to use color tools in GIMP.
Color Tools helps an user to manipulate the image colors in various ways.
How to Launch:
- Open GIMP.
- You can access the Color Tools through two ways.

The list of Color tools available are mentioned as below:
Color Balance -> Modifies the colour balance of current selection or layer.

Hue-Saturation -> Adjusts hue, saturation and lightness.

Colorize -> Renders current selection or layer into a grey scale image seen through colored 
glass.

Brightness-Contrast -> Adjusts brightness and contrast.

Threshold -> Transforms the current layer or selection into a black and white image.

Levels -> Changes the intensity range of the active layer or selection in every channel.

Curves -> Changes the color, brightness, contrast or transparency of the active layer or path.

Posterize -> Reduces the number of colors.
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Desaturate -> Converts all color to the corresponding shades of grey.
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How to Use Tool options in Toolbox

Topic

How to use tool options in GIMP toolbox?

Explanation

* The Tool Options are available to customize the options for a tool.
* Use the existing tool options to modify the options of an image.
* It is easy to access the "Tool Options" as it lies at the bottom of the toolbox.
How to Launch:
-> Launch GIMP.
-> Now you can see the toolbox at the right hand side of the screen.
How to Use:
-> Click any one of the available tools, For e.g. Select by Color - the options of the tool will be 
displayed at the bottom of the toolbox.

-> If you feel the tool options congested and if you like to see it separately, then do as mentioned 
below.
-> Click and drag the "Select by Color" tool out of the box.
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-> Then the Select by Color tool gets displayed in a separate box. The height and width of the box 
can be adjusted manually, as required.
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Rectangle Selection Tool

Topic

How to use rectangle selection tool in GIMP?

Explanation

* This rectangle selection tool enables you to make selections in a picture in rectangular shape.
* It is a trouble-free and a plain selection tool.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now select Rectangle Selection Tool from the toolbox.

* Shortcut for the rectangle tool is R. Click the Toolbox and then press the button R.
Tool options:
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Modes - It determines the way of creating the selection, i.e. whether it will be combined with existing 
one, etc.
Antialiasing - It causes the boundary of the selected portion to be drawn smoother.
Feather edge - It causes the boundary of the selected portion to be blurred.
Rounded corners - It rounds the corners of the selected portion. A slider appears after enabling this 
option. Use it to change the radius that is used to round the corners
Expand from centre - It expands the selection, using starting point as the centre, instead of the 
corner. After enabling this option, the starting point is used as the centre of the selection instead of 
using it as a corner. This also causes the selection to extend from all sides. This option can be 
enabled with Shift.
Fixed - It allows you to modify the actual shape of the rectangle through four available options 
namely, "Aspect Ratio, Width, Height, Size". It mainly focuses on the shape of an image.
Position - It is the placement of the selection.
Size - It is the size of the selection. The actual size of the current selection. You can use it to modify 
the size, as well as resize it directly on the image.
Highlight - It highlights the actual selection, by darkening everything that surrounds it. Emphasizes 
the selected area by a surrounding mask, making the visual selection much easier.
Guides - It picks the types of guides that are shown within the selection in-order to make the 
selection easier. The options available under guide are "No guides, center lines, Rule of thirds, 
Golden sections". It adopts the photo composition rules.
Auto Shrink - It shrinks the selection to the nearest rectangular shape available on the image layer. 
Select a portion in the image and then apply this option, which will shrink to the nearest rectangular 
shape within the selection. 
The algorithm for finding the best rectangle, can once do a great work, and sometimes find some 
strange rectangles.
Shrink merged - If it is enabled, the "Auto shrink" option will look on the actually visible image, 
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rather than the active layer.
* Utilize the "Shift" button to switch between the options available in the toolbox.
How to Use:
- Choose a portion of an image by using the rectangle selection tool. Just drag and leave the mouse.
[Note that the selection can be made only in the rectangular shape.View the below image]

- The selected portion in the image has been picked. Now the user can make use of this portion, 
either by slicing (cut) the selected portion or by having a copy of the image.
- Create a new file and then paste the selected portion. It is possible to paste the selected portion 
from where it has been selected.

- Finally, "Save" the file.
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Ellipse Selection Tool

Topic

How to use ellipse selection tool in GIMP?

Explanation

* It generates circle selection.
* Note that Round corner option is not available with this tool as it allows only circle selections.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now select Ellipse Selection Tool from the toolbox.

* Shortcut for this tool is E. Click the Toolbox and then press the button E(shortcut).
Tool options:
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* The operations of the above shown subsidiary tools of the Ellipse selection tool are same as the 
Rectangle tool.
Modes - It determines the way of creating the selection, i.e. whether it will be combined with existing 
one, etc.
Antialiasing - It causes the boundary of the selection to be drawn smoother.
Feather edge - It causes the boundary of the selection to be blurred.
Expand from centre - It expands the selection, using starting point as the centre, instead of the 
corner. After enabling this option, the starting point is used as the centre of the selection instead of 
using it as a corner. This also causes the selection to extend from all sides. This option can be 
enabled with Shift.
Fixed - It allows you to modify the actual shape of the rectangle through four available options 
namely, "Aspect Ratio, Width, Height, Size". It mainly focuses the shapes of an image.
Position - It is the placement of the selection.
Size - It is the size of the selection. The actual size of the current selection. You can use it to modify 
the size, as well as resize it directly on the image.
Highlight - It highlights the actual selection, by darkening everything that surrounds it. Emphasizes 
the selected area by a surrounding mask, making the visual selection much easier.
Guides - It picks the types of guides that are shown within the selection in-order to make the 
selection easier. The options available under guide are "No guides, center lines, Rule of thirds, 
Golden sections". It adopts the photo composition rules.
Auto Shrink - It shrinks the selection to the nearest ellipse shape available on the image layer. 
Select a portion in the image and then apply this option, which will shrink to the nearest rectangular 
shape within the selection. 
The algorithm for finding the best rectangle, can once do a great work, and sometimes find some 
strange rectangles. 
Shrink merged - If this option is enabled, then Auto Shrink will use the pixel information from the 
visible display of the image, rather than from the active layer. If this option is enabled Auto shrink 
will look on the actually visible image, rather than the active layer.
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How to Use:
- Simply drag and leave the mouse to choose any portion of the image using ellipse selection tool.
- Note that the selection will be made only either in circular or elliptical form.

- A portion in the image has been selected. The user can either cut or copy the selected portion.
- To paste the selected portion, just create a new file and then paste it. (View the below image)

- Finally, click "File->Save" to "Save" the file.
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Free Selection / Lasso Tool

Topic

How to use free selection / lasso tool in GIMP?

Explanation

* It enables a user to make free hand selections.
* Use this tool to create a selection by drawing through free hand with the pointer.
* You can commence free form selections either on new file or over an image.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now select Free Selection or Lasso Tool from the toolbox.

* Shortcut for this tool is F. Click the Toolbox and then press the button F.

Tool options:
* There are only three subsidiary options available under the free selection / lasso tool and they 
are listed below.
Modes - It determines the way of creating the selection, i.e. whether it will be combined with existing 
one, etc.
Antialiasing - It causes portion of the selection to be drawn smoother.
Feather edge - It causes the boundary of the selection to be blurred i.e. the image gets displayed 
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with less clarity.
How to Use:
- Now make free selection on the image. Simply click the portions which you require and complete 
the selection by ending where you have started the selection.

- The image portion (aeroplane) is selected in the above picture.
- Then copy or cut the selected portion.
- Create a new file and then paste it.

- To "Save" the file, simply click "File -> Save".Hscripts.com



Fuzzy Selection / Magic Wand Tool

Topic

How to use free fuzzy selection / magic wand tool in GIMP?

Explanation

* Fuzzy selection tool, also known as Magic wand tool, is used for choosing the portions of an 
image or layer with the same or similar colour.
* It is the best choice to pick objects with sharp edges.
* It is also adopted for touching the selected items or selecting areas within some curves or outline.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now choose Fuzzy Selection Tool from the toolbox. 

* Shortcut for this tool is U. Click the Toolbox and then press the button U(shortcut).
Tool options:

Modes - It determines the way of creating the selection, i.e. whether it will be combined with existing 
one, etc.
Antialiasing - This option causes the selected portion to be drawn smoother.
Feather edge - This option makes the portion of the selection to give a vague impression.
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Select Transparent Areas - This option gives the ability to select areas which are completely 
transparent.
Sample merged - This option creates a selection from actual image, instead from the active layer.
Threshold - This option determines the range of colours.
Select by - When it is selected, the component shall be used for calculating the similarity.
- The modes, antialiasing and feather edge options are available in all the selection tools.
How to Use:
- Now pick a portion from the image. Just drag the mouse over the image. (View the below image)

- The words in the above image has been selected. Now cut the selected portion from the image.
- Again launch a new file in GIMP.
- The selected portion gets pasted but it looks dim.

- At last, click "File -> Save" to "Save" the file.
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Select By Color Tool

Topic

How to Use Select By Color Tool in GIMP?

Explanation

* This Select by color tool is an alternate to the fuzzy selection tool.
* The By Color selection takes all the pixels with similar colour despite of where they are placed but 
the fuzzy selection tool selects portion without any gaps.
* As the fuzzy selection tool and by color selection tools are one and the same, the subsidiary 
options of these tools are also the same.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now choose Select By Color Tool from the toolbox. 

* Shortcut for this tool is Shift+O. Click the Toolbox and then press the button Shift+O.
Tool options:

Modes - It determines the way of creating the selection, i.e. whether it will be combined with existing 
one, etc.
Antialiasing - It causes the portion of the selection to be drawn smoother.
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Feather edge - It causes the portion of the selection to be blurred.
Select Transparent Areas - It gives the ability to select areas which are completely transparent.
Sample merged - It creates a selection from actual image, instead from the active layer.
Threshold - It determines the range of colours.
Select by - It select, which component shall be used for calculating the similarity.
How to Use:
- Now pick the Select by color tool. Then decide the color, which you want to select by color for e.g. 
Red.

- Just drag the mouse over the red color portion on the image. Note that if any portion of image (red 
color portion) is selected, then automatically its related colored portion in the image gets selected.

- Once selected, just cut or copy the selected portion.
- Create a new file and then paste the selected portion. Only the selected color will be pasted in the 
new file.
- In the below image, the chosen "Red" color is removed from the image.
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- Finally, click "File -> Save" to "Save" the file.
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Scissors Tool

Topic

How to use scissors tool in GIMP?

Explanation

* It generates a curve through the nodes, following the high-contrast which it identifies.
* Start the selection by clicking on the image. It will create a new anchor. Finish the selection just by 
clicking on the first node which you created in the beginning.
* It has some of the aspects of lasso and path tool.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Scissors Tool from the toolbox. 

- Click the Toolbox and then press the button I (shortcut).
Tool options:

Modes - It determines the way of creating the selection, i.e. whether it will be combined with existing 
one, etc.
Antialiasing - It causes the portion of the selection to be drawn smoother.
Feather Edge - It causes the boundary of the selected portion to be blurred.
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Interactive Boundary - The curves will be created instantly after creating a new node.
How to Use:
- Select any portion in the image.
- To select, just left click the mouse. This will create points. Start the selection and finish where you 
have started.

- Now press Enter To convert it into selection. 
- Then cut the selected portion and paste it a new file.

- Finally, click "File -> Save" to "Save" the file.Hscripts.com



Foreground Selection Tool

Topic

How to use scissors tool in GIMP?

Explanation

* It picks only the front portion of the image.
* An important thing is that you must press the Enter button after finishing the selection. Else you 
would actually lose the selection.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Foreground Selection Tool from the toolbox.

* There is no shortcut available for this tool.
Tool options:

Modes - It decides the way of creating the selection, which will be combined with existing one.
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Antialiasing - It causes the portion of the selection to be drawn smoother.
Feather Edge - It causes the boundary of the selected portion to be blurred.
Contiguous - Incase this option is enabled, only area contiguous to the stroke is selected. Only the 
areas contiguous to the stroke will be picked when this option is turned on. All the areas of the 
same colour in the rough selection will be chosen, when this option is turned off.
Interactive refinement - Adjusts the settings for the brush.
Smoothing - It controls the smoothness of selection. This slider lets you to remove holes in the 
selection. The smaller values may generate better borders.
Preview colour - The colour used to cover the background portion of the image. There are only 
three colors available - red, green and blue.
Colour Sensitivity - This option sets the sensibility for colours of the selection. If your image 
contains many pixels of the same color in different tones, you can increase the sensibility of the 
selection for this colour.
How to Use:
- First select any portion on the image using this tool. Note that user can also make "rough or free 
hand selection" selection.

- Click the left mouse button and the paintbrush tool will be activated.
- Then drag inside the selected portion in the image.

- Now press the Enter button. The selected portion in the image gets picked.
- After that, click Brightness-Contrast to adjust the color patterns of the image.
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- In the Brightness-Contrast box, set the values and click the "Ok" button.

- Now click the Move tool from toolbox.

- Simultaneously launch a new file.(View the below image)
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- Then move the previously selected image file and paste it in the newly opened file.
- Note that it would give a better result if the newly opened image is suitable to the previously 
launched file.
- In the below image, the selected portion (Blue Rose) is perfectly placed inside the newly launched 
file.

- Finally, click "File -> Save" to "Save" the file.

Hscripts.com



Bucket Fill Tool

Topic

How to Use Bucket fill Tool in GIMP?

Explanation

* This bucket fill tool helps the user to fill the color on an image.
* This tool fills the default Foreground Color over the selected portions on the image.
* It spreads the selected area either with a color or pattern.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Bucketfill Tool from the toolbox.

* Shortcut for this tool is Shift + B. Press the button Shift + B.
Tool options:

Hscripts.com

Hiox.com

https://www.hscripts.com/tutorials/gimp/bucketfill-tool.html
https://hiox.com


Mode - The list of available options enables filling up the image.
Opacity - This option in an image will make the background to be unclear or vague when the image 
is filled with color.
Fill Type - Fill up the selected area with the Foreground, Background color or Pattern. The variety of 
pattern types are provided in the list box.
Affected Area - Fill up the whole portion or else fill up the chosen areas in the image.
Finding Similar Colors - There are two subsidiary options available under this option.
1] Fill Transparent Areas -> It fills the color in the selected portion of an image with low opacity.
2] Sample Merged -> It toggles sampling from all the layers. If it is made active, then the filling will 
be done on lower layer. Set the lower level in threshold and make sure that the layer on the image 
is visible for color weighting.
Threshold - Threshold slider fixes the level at which the color weights are measured for fill 
boundaries. To activate this option, user needs to set the Fill similar colors. It fills the colors 
darkly, if higher settings are applied.
Fill By - User can choose one of the six components (Red, Blue, Green or with the Hue, Saturation, 
Value, Composite) so that GIMP can calculate the similarity and also determine the borders of filling 
for an image.
How to Use:
- Open any image file.
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- First decide the color to be used to fill the image.
- Choose either "Foreground or Background" color" in the toolbox. For e.g. the Background Color
has been selected below. The default background color is White. (View the below image)

- You can view the Preview of the image in the right hand side of the toolbox.
- Now simply click the left mouse button on the image to fill the background color on the image. The 
image is filled the background color.

- At last, click "File -> Save" to "Save" the file.
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Blend / Gradient Tool

Topic

How to Use Blend / Gradient Tool in GIMP?

Explanation

* This  blend/gradient tool generally fills an selected portion with the gradient blend of the default 
Foreground and Background Colors.
* The gradient is a paint to fill or stroke, which smoothly blends from red to green color.
* In-order to blend you need to drag the cursor, in which you want the gradient to be obtained.
How to Launch:
- Open Gimp.
- Launch a new file.
- Now pick Blend Gradient Tool from the toolbox.

* Shortcut for this tool is L. Click the Toolbox and then press the button L.
Tool options:

Mode - It determines the way of creating the selection, i.e. whether it will be combined with existing 

Hscripts.com

Hiox.com

https://www.hscripts.com/tutorials/gimp/blend-gradient-tool.html
https://hiox.com


one, etc.
Opacity - It sets the gradient to be see-through or fully noticeable.
Gradient - This option is a type of gradient.
Offset - It permits to raise the slope of an gradient. It also determines the launching of gradient. This 
option will not affect the "Shaped Forms".
Shape - This option is the shape of the gradient.
Repeat - This option is like Undo.
Dithering - It helps to reduce banding by dithering the gradient.
Adaptive supersampling - It refines the gradient in high contrast areas. It smoothens jagged effect 
of the sharp transition of color through the slanted or curved lines.
How to Use:
- Initially choose the type of blend option from the toolbox. Click the "Active Gradient" in toolbox.

- Then choose any one type of gradient.

- Simply drag the cursor in the direction where you want to apply the gradient and then release the 
left mouse button.
- You can view the processing of blending.

- The gradient has been applied to the image.
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- Finally, click "File -> Save" to "Save" the file.
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Pencil Tool

Topic

How to use pencil tool in GIMP?

Explanation

* It draws hard-edged lines on a image.
* It is used to sketch in an image with free hands.
* It wont produce fuzzy borders or anti aliasing.
How to Launch:
- Open Gimp.
- Launch a new file.
- Now pick Pencil Tool from the toolbox.

* To select, click the Toolbox and then press the button N(shortcut).
Tool options:
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Mode - The list of available options enables to fill up the image.
Opacity - This option in an image will make the background to be unclear or vague when the image 
is filled with color.
Brush - This option lists you with the types of brushes, which can be used to write or else paint the 
image.
Scale - This option maximizes or minimizes the size of the pencil tool.
Brush Dynamics - The Pressure, Velocity and Random aspects will be added to the tool.
Fade Out - This option enables the pencil tool to be lighter when it is used on the image.
Apply Jitter - Instead of drawing on an image, this option simply spreads the color particles on the 
image which looks so attractive.
Incremental - This is an additional option used to draw.
Use color from gradient - This option list you with plenty of Gradient types, which helps you in 
drawing on the image.
How to Use:
- First set the tool options in the toolbox. Particularly the Shapes.
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- Then click the left mouse button.
- The shapes will be applied in the file. If you have not picked any shapes, then simply a line is 
applied on the file.

- To increase the size of the pencil brush in toolbox, simply click the "Brush" option and select the 
size from it.
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- At last, click "File -> Save" to "Save" the file.
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Paintbrush Tool

Topic

How to use paintbrush tool in GIMP?

Explanation

* It paints in a soft manner or provides fuzzy-edged lines.
* It simply strikes using the brush and enables the pixels to be anti-aliased.
How to Launch:
- Open GIMP.
- Launch a new image file.
- Now pick the "Paintbrush Tool"

- Shortcut for this tool is P. To pick this tool, click the Toolbox and then press the button P.
Tool options:
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Mode - The list of 23 options enables you to manipulate an image.
Opacity - This option will make the background of an image vague when the image is brushed.
Brush - This option lists you the types of brushes and shapes to paint the image.
Scale - This option maximizes or minimizes the size of the Paintbrush tool.
Brush Dynamics - The Pressure, Velocity and Random features are mixed with the Opacity, 
Hardness, Size, Color.
Fade Out - This option makes the paintbrush to gradually paint and disappear, while using it on the 
picture.
Apply Jitter - This option is used to spread the color particles on the image which looks so attractive.
Incremental - This is an additional option used to paint.
Use color from gradient - This option provides you with plenty of Gradient types or color patterns, 
which helps you in drawing on the image.
How to Use:
- Primarily, it paints the selected color in the image or even in new image file.
- First, set the options in "Mode, Opacity, Scale, Brush Dynamics" in toolbox. Then pick "Fade out, 
Apply Jitter, Incremental & use color from gradient" options if necessary.
- Then choose the type of Shape in the toolbox. 
- The brush will simply paint, if you had chosen the brush option.
- Pick different types of shapes, sparks available in brush option.
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- A sample "sparks and shapes" has been created using this tool. (View the below image)

- Try with different types of shapes to create new designs using paintbrush.
- Finally, click "File -> Save" to "Save" the file.
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Eraser Tool

Topic

How to use eraser tool in GIMP?

Explanation

* This tool is applied to get rid of the selected part of an image.
* Make use of this tool to take away the unwanted portions in an image.
* Each individual pixels on the image can be eradicated using this Erase Tool.
How to Launch:
- Open Gimp.
- Now pick Eraser Tool from the toolbox.

* To select, click the Toolbox and then press the button Shift + E (shortcut).
Tool options:
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Mode - The mode option cannot be enabled when Eraser tool is selected.
Opacity - This option will make the background of an image blurred.
Brush - This option offers you with a list of tools or items that can be utilized to remove the selected 
portions of an image. Tools from small to larger size are made available with this option.
Scale - This option helps to obtain the pointer from minimium to maximum size.
Brush Dynamics - The Pressure, Velocity and Random features of the "Opacity, Hardness, Size".
Fade Out - This option makes the eraser tool to gradually remove and make the image fainter.
Apply Jitter - This option in eraser tool is used remove the larger portions of the image at a time in 
circular shape.
Incremental - This is an additional option used to paint.
Hard Edge - This option clearly removes the borders or curves of selected areas and evades limited 
removal at the edges.
Anti Erase - This option can be used only on the layers of an image. This option is used to recover 
or obtain the portions which were removed accidentally or by mistake.
How to Use:
- Open any image file.
- set the options in toolbox as per your requirements.

- Then decide which portion of the image needs to be removed.
- Just click the left mouse button and drag the cursor over the image.
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- Now the selected portion in the image has been removed. (View the highlighted portion in the 
above image).
- User can also utilize the "Shapes" available in the brush option in toolbox. Note that the brushes 
or shapes, when applied, will result in the removal of the image.
- At last, click "File -> Save" to "Save" the file.
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How to Use Airbrush Tool

Topic

How to Use Airbrush Tool in GIMP?

Explanation

* Airbrush tool is used to paint the image with a variable pressure.
* This tool is the convenient tool to paint an image.
* It can be regarded as the traditional airbrush.
* It suits well to paint the smoother areas of color.
* When compared to the paintbrush tool, it is slightly difficult to operate/handle.
How to Launch:
- Open Gimp.
- Launch a new file.
- Now pick Airbrush Tool from the toolbox.

* To select, click the Toolbox and then press the button A (shortcut).
Tool options:
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Mode - The list of 23 options enables you to modify an image with different options.
Opacity - This option increases the strength of the tool and also makes the background of an image 
vague when the image is brushed.
Brush - This option provides you various types of brushes or shapes to paint the image.
Scale - This option is used to maximize or minimize the size of the Airbrush tool. 
Brush Dynamics - The Pressure, Velocity and Random features are mixed with the Opacity, 
Hardness, Size, Rate and Color to offer a different feature to the tool.
Fade Out - This option makes the airbrush to give a paler effect to the paint that has been applied 
on the image i.e. the color painted turns fader.
Apply Jitter - This option is used to spread a variety of colors on the image which makes the picture 
so attractive.
Use color from gradient - This option provides you with plenty of Gradient types or color patterns, 
which helps you in drawing on the image.
Rate - It configures the speed of the color application. Maximum level of rate will exhibit sharp and 
dark brush strokes.
Pressure - This option determines the level of pressure - whether to be high or low. The effect of 
this option can be felt when it is applied on an image.
How to Use:
- Open a new file.
- Note that this tool simply helps in painting and to apply colors to an image file.
- It would be effective when the additional brush or shapes are added to this tool.
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- First decide the color to be used to fill the image.
- Set the options and apply it on new file or even on image files to acquire a new designed image.
- At last, click "File -> Save" to "Save" the file.Hscripts.com



Ink Tool

Topic

How to use ink tool in GIMP?

Explanation

* The Ink tool paints the anti-aliased enabled lines with the simulation of pointer.
* Ink tool can be simply denoted as Calligraphy Style Painting.
* The position, shape and size of the pointer can be set in advance to execute the strokes on an 
image.
How to Launch:
- Open Gimp.
- Launch a new file.
- Now pick Ink Tool from the toolbox.

* To choose this tool, click the Toolbox and then press the button K (shortcut).
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Tool options:
Mode - The list of 23 options enables you to modify an image with different tool options.
Opacity - This option increases the strength of the tool and also makes background of an image 
vague when the image is brushed.
Adjustment - The Size and Angle of the nib or pointer is controled by this option.
Sensitivity - This option raises or minimizes the level of the pointer in filling the ink on the image. 
This tool controls the size, tilt and speed of the pointer or nib.
Type - This option allots you three different shapes namely Circle, Cube, Hexagon to apply on an 
image.
How to Use:
- Open new file.
- Intially set the options in tool options in the toolbox.
- The options "Mode, Opacity, Adjustment, Sensitivity & Type" plays an important role in applying 
the color to a file. So set these options as per your need.
- Unlike other "Brush Tools", the ink tool does not possess brush option. Instead of it, the Type
option can be picked to apply shapes.

- A sample of shapes has been created using the ink tool. (View the below image)

- At last, click "File -> Save" to "Save" the file.
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Clone Tool

Topic

How to use clone tool in GIMP?

Explanation

* It simply reproduces the selected portions in an image.
* It copies the pixels from the selected part of an image and it can be pasted in any side.
* User can also copy Patterns. 
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Clone Tool from the toolbox.

* To select, click the Toolbox and then press the button C (shortcut).
Tool options:
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Mode - The list of 23 options helps you to apply different features to the clone tool.
Opacity - This option raises the strength of the tool and also it makes the background of an image 
to be unclear when the image is cloned.
Brush - This option provides you various types of brushes or shapes to paint the image.
Scale - This option is used to maximize or minimize the size of the Clone stamp tool.
Brush Dynamics - The Pressure, Velocity and Random features are combined with Opacity, 
Hardness, Size to set the features to the pointer of the clone tool.
Fade Out - This option makes the pointer to decrease the color that has been applied on the image 
i.e. the color is applied in large manner initially and then it gets fainted.
Apply Jitter - This option is used spread the variety of colors on the image which makes the image 
catchy enough.
Hard Edge - This option produces thick colors, specially concentrates on the curves.
Source - This option offers two additional options Image and Pattern. Either the pixels of the image 
can be copied or the patterns can be applied on the image.
Alignment - This option fixes the pointer and its source position. This option offers three variety of 
alignments namely Aligned, Registered and Fixed or else the none option can be choosed to 
unselect any alignment option.
How to Use:
- First press Ctrl button to start the selection. 
- Now drag the cursor on the required portions in the image, for which you like to clone.
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- Note that you must press Ctrl button until the selection is over. Then leave the cursor on the 
dragged portion of the image. 
- Now leave the ctrl button and click the left mouse button and drag in the empty place of the file.
- Suddenly a Pointer arises on the original portion of the image on where you have cloned and also 
placed the cursor.
- The "Pointer" which is located at cloned section will move when you move the mouse. 
Simultaneously the cloned section is reproduced.

- Just drag the "Pointer" on the cloned portion of the image. Then automatically the "Cursor" will 
reproduce the image.
- Now the whole image has been cloned. (View the below image)

- Finally, click "File -> Save" to "Save" the file.
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Healing Tool

Topic

How to use healing tool in GIMP?

Explanation

* It eradicates the uneven or unbalanced pixels in an image by replacing uneven pixels.
* It simply removes the irregularities of a picture.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick Healing Tool from the toolbox.

* To select, click the Toolbox and then press the button H(shortcut).
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Tool options:
Mode - The available 23 options enables the user to set different features to the Healing tool.
Opacity - This option increases the strength of the tool.
Brush - This option provides you a list of pointers or shapes to heal the picture.
Scale - This option maximizes or minimizes the size of the heal tool.
Brush Dynamics - The Pressure, Velocity and Random features are combined with Opacity, 
Hardness, Size to apply the features to the pointer of the heal tool.
Fade Out - This option makes the airbrush to give a paler effect to the paint that has been applied 
on the image i.e. the color painted turns fader.
Apply Jitter - This option is used spread the variety of colors on the image which makes the image 
look catchy.
Hard Edge - This option delivers thick colors when it is applied and particularly concentrates on the 
curves.
Sample Merged - This option makes the heal tool to calculate the values of the active and visible 
layers.
Alignment - This option fixes the position of brush and its source position. It provides three 
alignment options namely Aligned, Registered and Fixed. You can also select the "None" option 
to deselect the alignment option.
How to Use:
- Press Ctrl button and start the selection.
- Simply drag the cursor over the image. Do not leave "Ctrl" button until the selection is over.
- User can do the healing in any portion of the currently opened image or else launch another image 
file and do the healing process.
- It would be better to launch another new image file.
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- Click on any portion in the newly launched file.
- Now the Pointer is displayed on the previously opened image.
- Then click and drag the cursor on the newly opened image.
- The healed portion will be reproduced.
- At the same time, the pointer in the image moves like + symbol. (View the below image)

- Then continue the same. Just drag the cursor on the image where you like to heal.
- Now the image is healed. (View the highlighted portion in the below image)
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- Finally, click "File -> Save" to "Save" the file.
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Perspective Clone Tool

Topic

How to use perspective clone tool in GIMP?

Explanation

* Perspective clone tool helps to copy as per your likings.
* This tool, after enabling the perspective transformation, copies the source of an image.
* There is no shortcut assigned for this tool.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Perspective Clone Tool from the toolbox. 

Tool options:
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Modify perspective - This mode is used to copy the layers, paths and selected portions of an image.
Perspective clone - This mode is used to clone/copy the image.
Mode - This option lists 23 paint application tools that enables the user to apply more aspects to the 
Perspective clone tool.
Opacity - This option decides the transparency level when the pointer is used.
Brush - This option decides the type of pointers to clone an image.
Scale - This option allows you to alter the size of the pointer of the tool.
Brush Dynamics - The Pressure, Velocity and Random features are combined with Opacity, 
Hardness, Size to apply the features to the pointer of the perspective clone tool.
Fade Out - This option makes the airbrush to give a paler effect to the paint that has been applied 
on the image i.e. the color painted turns fader.
Apply Jitter - This option is used spread the variety of colors on the image which makes the image 
look catchy.
Hard Edge - This option delivers thick colors when it is applied and particularly produces darker 
color effects when it is applied severely.
Source - This option offers two additional options Image and Pattern. Either the pixels in the image 
can be copied or the Pattern can be applied on the image.
Alignment - This option fixes the position of brush and its source position. It provides three 
alignment options namely Aligned, Registered and Fixed. You can also select the "None" option 
to deselect the alignment option.
How to Use:
- First press Ctrl button to start the selection. 
- Now drag the cursor over the required portions on the image, which you like to clone.
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- Note that you must press Ctrl button until the selection is over. Then leave the cursor on the 
dragged portion of the image. 
- Now leave the ctrl button and click the left mouse button and drag to the empty place of the file.
- A Pointer arises on the original portion of the image where you have cloned and placed the cursor.
- The "Pointer" which is located at cloned section will move on when you move the mouse. 
Simultaneously the cloned section is reproduced.
- Just drag the "Pointer" on the cloned portion of the image. Then automatically the "Cursor" will 
reproduce the image.
- Now the whole image has been cloned. (View the below image)

- Finally, click "File -> Save" to "Save" the file.
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Blur Tool

Topic

How to Use Blur Tool in GIMP?

Explanation

* It is also referred as Sharpen Tool.
* When it is applied, it makes the image to be unclear or less distinct.
* The brush of this tool blurs or sharpens, when it is applied over an image.
* It can also be used to soften an image.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick the Blur Tool from the toolbox.

* The shortcut available for this tool is Shift + U.
- To select, click the toolbox and press the button Shift + U.
Tool options:
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Mode - This option is not enabled in the  blur tool.
Opacity - This option determines the transparency level, when the pointer is used.
Brush - This option exhibits different type of pointers to blur an image.
Scale - This option allows you to select the size of the pointer of the blur tool.
Brush Dynamics - The Pressure, Velocity and Random features are combined with Opacity, 
Hardness, Size to apply the features to the pointer of the blur tool.
Fade Out - This option makes the airbrush to give a paler effect to the paint that has been applied 
on the image i.e. the color painted turns fader.
Apply Jitter - This option is used spread the variety of colors on the image which makes the image 
look catchy.
Hard Edge - This option executes dark colors when it is applied consecutively on a particular 
portion.
Convolve Type - Two additional options are available under this type.
1]Blur -> This option makes all the pixels to mingle with each other.
2]Sharpen -> This option causes each pixel to be different from each other.
Rate - This option strengthens the blur or sharp effect on the image.
How to Use:
- As usual set the required tool options in toolbox.
- Now click the left mouse button and drag the mouse over the required portions on the image.
- The dragged portion in the image gets blurred or dim, when the the tool is applied on it again and 
again.
- Press Ctrl button to make the image look more blurred.
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- Now the image gets blurred. (View the below image)

- Finally, click "File -> Save" to "Save" the file.
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How to Use Smudge Tool

Topic

How to use smudge tool in GIMP?

Explanation

* It is used for smearing colors on a selected layer. 
* It handles the pointer to smudge the colors on the path or on the layer or on the selected portion 
of an image.
* When it is applied on an image, it picks the available color and mixes it with the colors present on 
the image.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick Smudge Tool from the toolbox.

* To select this tool, click the toolbox and press the button S.
Tool options:
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Mode - This option is not applicable for this tool.
Opacity - This option is used to set the transparency level for the pointer.
Brush - This option offers different types of pointers to smudge an image.
Scale - This option allows you to set the size of the pointer.
Brush Dynamics - The Pressure, Velocity and Random features are combined with Hardness 
and Rate to set the features to the pointer of smudge tool.
Fade Out - This option makes the airbrush to give a paler effect to the paint that has been applied 
on the image i.e. the color painted turns fader.
Apply Jitter - This option smudges the image quicker than other smudging options.
Hard Edge - This option places colors in a rough manner when it is applied on a selected portion of 
an image.
Rate - This option smudges harder when it is applied on an image.
How to Use:
- First choose the type of brush from the tool options in toolbox.
- Then click and drag the cursor on the required portion of the image. For e.g. in the below image, 
the text is smudged.

- When mouse is dragged over the text portion, it gets smudged.
- In the below image, you can find that all the texts are smudged.
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- Now click "File -> Save" to "Save" the file.
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Dodge / Burn Tool

Topic

How to use dodge / burn tool in GIMP?

Explanation

* It casts shadow and lightens an image.
* It highlights or darkens an image on the selected portions.
* The Dodge option "lightens" the image and Burn option "darkens" an image.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick Dodge/Burn Tool from the toolbox.

* To select, click the toolbox and press the button Shift + D (shortcut).
Tool options:
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Mode - This option is not enabled in Dodge/Burn tool.
Opacity - This option sets the transparency level for the pointer of dodge / burn tool.
Brush - This option provides different kinds of pointers to dodge/burn an image.
Scale - This option is used to set the size of the dodge/burn pointer.
Brush Dynamics - The Pressure, Velocity and Random features are mixed with Opacity, 
Hardness and Size to set the features to the pointer of dodge tool.
Fade Out - This option makes the airbrush to give a paler effect to the paint that has been applied 
on the image i.e. the color painted turns fader.
Apply Jitter - This option dodges/burns the pixels of the image faster.
Hard Edge - This option executes darker colors when it is applied on an image frequently.
Type - This option allows you to choose Dodge/Burn mode.
1]Dodge -> The colors on an image will be lightened or softened.
2]Burn -> It completely brightens the colors in an image.
Range - This option lists you three further options namely, Shadows, Midtones, Highlights.
1]Shadows -> It limits the outcome of the darker pixels.
2]Midtones -> It confines the influence of the pixels which are normal ones.
3]Highlights -> It puts a limit to the outcome of lighter pixels
Exposure - This option determines the level of the dodge/burn tool's effect.
How to Use:
- Simply click left mouse button and drag the cursor over the image.
- Now the image gets lightened because the default mode is set as "Dodge" in toolbox. (View the 
below image)
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- Use Ctrl button to switch between "Dodge and Burn" options.
- Now choose "Burn option". Just click ctrl button and drag the cursor over the image.
- The image gets darker.(View the below image)

- To "Highlight" an image more, just select the highlight option under the "Range" tool in the toolbox.

- The below image is highlighted using the highlight option.

Hscripts.com



- Try the rest of the tool options in the toolbox and finally click "File -> Save" to "Save" the file.
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Move Tool

Topic

How to use move tool in GIMP?

Explanation

* Move Tool generally shifts or moves layers and selections.
* This tool is used to move layers, paths, guides in an image.
How to Launch:
- Open Gimp.
- launch a new image file.
- Now pick Move Tool from the toolbox.

- Shortcut for this tool is M. To select, just click the toolbox and then press the button M.
Tool options:

Move - This option states what will be transformed/moved. That is, you can pick what you want to 
shift - the layers, selected portion or the path.
Tool Toggle - This option helps to switch from one option to another.
How to Use:
- Launch a new image file.
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Pick Layer
- Select the entire image.
- Now choose the Pick a layer or guide under the "Tool Toggle" menu in toolbox.

- Just click and drag on any portion of the image.
- The layer gets moved as you move the cursor.

Move Layer
- Set Move the active layer tool option under the "Tool Toggle" menu in toolbox.
- Just click "Ctrl+A" to select the whole image.
- Now click and drag the cursor on the image.
- Automatically the layer is moved from its source position.
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Pick Path
- Click the Path menu in the toolbox.

- First set the Pick a path tool in toolbox.
- Now drag the cursor over the image. It turns into a small hand when it is moved over the visible 
path.
- Simply click and drag to move the path. Note that only the active path will move.
Move Path
- Pick the Move the active path tool in toolbox. 

- Now click and drag the cursor over the image.
- The current path gets moved. The plus symbol appears while moving the path. (View the below 
image)
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- User can change the current path in the Path Dialog.
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Alignment Tool

Topic

How to Use Alignment Tool in GIMP?

Explanation

* It organizes the layers or paths of an image.
* It helps in Placing the things in proper chosen positions.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Alignment Tool from the toolbox.

* To select, click the Toolbox and then press the button Q(shortcut).
Tool options:
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Relative To - Alters the edges in connection to the left, right, center, top, bottom and middle of the 
selected target by applying Selection option. The rest of the options are used to align the layer, 
path and channel.
Distribute - Distributes the left, right, center edges, top, bottom and middle edges of the chosen 
target.
Offset - Sets the desired value to align the image.
How to Use:
- Move the cursor over the image. Now the cursor turns into a small hand. 
- Just click on the image.
- To add the layer to list, press Shift button and click on the image.
- Now set any one of the options under the menu "Relative to", for e.g. Active layer

- Then enter the value in Offset.
- Click any one of the buttons under the "Distribute" menu, for e.g. Right button.

- The image gets moved towards the right side from its source position.
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- To align the image, just select any one of the options under the relative tool, for e.g. "Selection".
- This option will make the selected layer in image to be aligned.
- Then select the entire image.
- Click any one of the arrow buttons under the "Align" option to align the image.
- Then the image gets aligned as per the direction chosen in the align option.
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Crop Tool

Topic

How to use crop tool in GIMP?

Explanation

* Crop tool erases the edge portion of an image or layers.
* It is applied to trim or clip the image/the layers inserted on the images.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Crop Tool from the toolbox.

- To select, click the Toolbox and then press the button Shift + C (shortcut).
Tool options:
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Current layer only - This option can be utilized only on the current layer.
Allow Growing - This option enables to enlarge beyond borders.
Expand from centre - This option makes the picked portion to become bigger. This tool employs the 
starting point as the centre, as a replacement for the corners.
Fixed - It allows you to alter the predefined shape of the rectangle.
Position - This acts as the placement of the selection.
Size - This is the length/size of the selection.
Highlight - This tool emphasizes the marked selection, by darkening everything that lies at the 
backdrop of the image.
Guides - It chooses the types of guides available within the marked portion.
Auto Shrink - This tool minimizes/reduces the size of the selection to the nearest rectangular shape 
located on the image layer.
Shrink Merged - Incase this option is made active, then the Auto Shrink tool will assume the pixel 
information from the visible display of the image, instead from the active layer.
How to Use:
- To simply crop an image, just select the required portion in the image.
- Click the left mouse button on the image, the cursor turns into plus symbol and now select the 
portion.

- After selection, press or hit Enter button.
- The image gets cropped now.
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- The Expand from center tool option enables to make selections, just from the expansion of tool 
itself.
- First click on any portion of the image, then drag the cursor to make selection. The selection 
portion gets expanded from the centre part of the selection point.

- Then press enter to crop the image.

- The rest of the tool options like Current layer only, Allow growing, Fixed, Highlight, Auto shrink & 
Shrink merged options help the user to crop an image by applying the available options under it.
- Apply the Current Layer Only tool option to crop active layer.
- Use the Allow Growing tool option to crop outside the image.Hscripts.com



Rotate Tool

Topic

How to use rotate tool in GIMP?

Explanation

* It revolves the layer, paths and selected portion in the image.
* It helps to spin an image in different directions. The subsidiary options enables obtaining various 
transformed positioned images.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Rotate Tool from the toolbox.

- To select, click the Toolbox and then press the button Shift + R (shortcut).
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Tool options:
Direction - This option enables turning an image either in the Normal or Corrective manner.
1] Normal -> This option rotates the image in the forward position.
2] Corrective -> This option rotates the image in the opposite direction i.e. towards backwards, 
against the option set in the box.
Interpolation - This option helps to curve the image. It takes samples from a grid of pixels from 
known image areas, then attempts to fit the curve, after that uses those samples to value the 
unknown image areas.
Clipping - This option helps to cut the image.
Preview - It helps an user to see the preview of an image. The subsidiary options available are 
Outline, Image, Grid. The Image and Grid can be used together in an image and viewed or else just 
the outline/image option can be seen separately.
Opacity - This option in an image will make the background to be unclear or vague when the image 
is filled with color.
Number of grid lines - Set the Grid option in preview to enable this option. This option lists the Grids
which are placed on the image while making changes.
15 degrees - This is default option to turn an image by 15 degrees.
How to Use:
- Basically there are two ways to rotate an image.
- The two methods are - Normal (Forward) and Corrective (Backward).
- The "Normal" option rotates an image in forward direction and "Corrective" option rotates an 
image in backward direction. The rotation depends upon the values entered in the rotation box.
- First set the tool option as "Normal" and click on the image.
- The Rotate box is displayed.

- Now enter the values in "Angle" column and also in "X & Y" coordinates.
- You can view the rotation of the image while entering values in the rotate box.
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- Now click the Rotate button in rotate box.
- The image is rotated in forward direction.

- Some additional values applied in the Interpolation, Clipping, Preview will include more features 
when an image is rotated.
- Now set the option as Corrective, then click the image and in the "Rotate" set the values, click the 
"Rotate" button.
- Note that the image will be rotated backwards as per the values entered in the rotation box.
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- The Clip tool option will chop the selected portions of an image, at when it is rotated.

- Utilize the rest of the tool options to have a perfectly rotated image.
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Scale Tool

Topic

How to use scale tool in GIMP?

Explanation

* It is used to adjust the size of the layer, paths and selected portion in the image.
* It expands or scales down the size of the image.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick Scale Tool from the toolbox.

* To select, click the Toolbox and then press the button Shift + T (shortcut).
Tool options:
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Direction - This option allows you to scale an image either in the Normal or Corrective manner.
1) Normal -> This option scales the image in the forward position.
2) Corrective -> This scales the image in the backward position.
Interpolation - This option helps to curve the image. 
Clipping - This option slashes an image.
Preview - It helps an user to see the preview of an image. The subsidiary options available are 
Outline, Image, Grid. The Image and Grid can be viewed at once or else just the outline/image can 
be seen separately. 
Opacity - This option in an image will make the background to be vague when the image is filled 
with color.
Number of grid lines - Set the Grid option in preview menu to activate this option. This option lists 
the Grids which are placed on the image while applying the settings.
Keep Aspect - This option can be made as default using the Ctrl button.
How to Use:
- To scale an image in forward direction, set "Normal" option and to scale image in backward 
direction, set "Corrective" option.
- First, set either Normal or Corrective tool option in toolbox.
- Then, click on any portion on the image.
- The Scale box gets displayed.

- Now enter the values i.e. "Height and Width" in concerned columns and click the button "Scale".
- User can view the adjustments or scalling of an image, at when the values was entered in the 
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scale box.
- The below image has been scaled in forward direction.

- Set the Corrective option, enter the values and click the "Scale" button in Scale box.
- The below image has been scaled in backward direction.

- After scaling an image, you can take a copy of it and expand or minimize it, without using any 
tools or options.
- Just click on the image.
- The image gets selected automatically. Now click the + symbol and pull the image from its source 
position.
- Now use the borders to maximize or minimize the image.

- The copied image wont have much clarity as the original one. But it if enlarged to its original size 
then it will look effective.
- Use rest of the tool options in scale tool to scale an image efficiently.
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Shear - Transform Tool

Topic

How to use scale tool in GIMP?

Explanation

* It makes the layers of the image to shift from the current position.
* It is used to commence changes in the position of the image.
* The image gets moved or shifted when the horizontal & vertical coordinates of the image are 
altered.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now select the Shear Tool from the toolbox.

- Shortcut for this tool is Shift + S. To pick this tool, click the Toolbox and then press the button Shift 
+ S.
Tool options:
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Direction - This option shears an image either in Normal direction or in Corrective direction.
1)Normal -> This option shears the image in the forward position.
2)Corrective -> This shears the image in the backwards position.
Interpolation - This option helps to curve the image.
Clipping - This option slices the image.
Preview - It helps an user to see the preview of an image. The subsidiary options available are 
Outline, Image, Grid. The Image and Grid options can be used together and viewed (image with 
grids) or else the outline/image can be used separately on an image to view the outline.
Opacity - This option in an image will make the background to be vague when the image is filled 
with color.
Number of grid lines - Set the Grid option in preview to enable this option. This option lists the Grids
which are placed on the image while making changes.
How to Use:
- To shear, either go for "Normal or Corrective" tool option. The normal option is set as default in 
toolbox.
- First click on any portion of the image.
- The Shear box gets displayed.

- Set the X & Y Coordinates and click the "Shear" button.
- Now the image has been sheared in forward direction.
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- To shear an image in backward direction, just set the Corrective tool option in toolbox and click on 
the image.

- The Shear box gets displayed. Then enter the value and click the "Shear" button.

- The image is sheared in backwards direction.

- The Preview tool option in toolbox lists four options.
- Based upon the option, before shearing the image, the selection outline will be displayed.
- Pick any one of the options under it, for e.g. Grid.
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- Now click on the image. The image is filled with the grids.

- Utilize the tool options like Interpolation & Clipping to adjust the direction and preview of an image.
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Perspective Tool

Topic

How to use perspective tool in GIMP?

Explanation

* It modifies the perspective of the "layer, selection or path".
* It helps the user to change the View of an image.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick Perspective Tool from the toolbox.

- To select, click the Toolbox and then press the button Shift + P (shortcut).
Tool options:
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Direction - This option allows you to scale an image either in the Normal or Corrective manner in 
the perspective tool.
1) Normal -> This option scales the image in the forward position.
2) Corrective -> This scales the image in the backwards position.
Interpolation - This option helps to curve the image. 
Clipping - This option clips or trims the image.
Preview - Four options come under this Preview menu. The options are Outline, Image, Grid and 
Image and Grid.
Opacity - This option in an image will make the background to become vague when the image is 
filled with color.
Number of grid lines - Set the Grid option in preview to enable this option. This option lists the Grids
which are placed on the image while making changes.
How to Use:
- Perspective of the layer can be modified to either forward or backward direction.
- By default, the option is set as Normal (Forward) direction.
- Now click on the image. The Perspective box gets displayed.

- Now click on any portion of the image.
- The selection outline is displayed. Click on the plus (+) symbol to alter the perspective of the 
image.
- Click and drag the outline to change the borders of the outline.
- After altering the outline, just click the Transform button in the "Perspective" box.
- The perspective of the image will be transformed in normal direction.
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- Now let us see how to alter the perspective of an layer to backward direction.
- Set the tool option as Corrective in toolbox.
- As usual click on the image and the selection outline appears.
- Then alter the outline as per your requirement.
- You can view the changes in measurements while altering the selection outline. (View the below 
image)

- After modifying the outline, just click on the Transform button in the "Perspective" box.
- The image will be transformed in the opposite direction. (View the below image)

- Use the Interpolation, Clipping & Preview tool option in the toolbox to modify the layer effectively.
- Finally, click "File->Save" to save the file.
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Flip Tool

Topic

How to use flip tool in GIMP?

Explanation

* Flip tool is utilized to turn image either in horizontal or in vertical direction.
* It enables the user to generate the existing image in both different horizontal and vertical postures.
* This tool helps to achieve transformed image positions in horizontal or vertical directions.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick Flip Tool from the toolbox.

* To select, click the Toolbox and then press the button Shift + F (shortcut).
Tool options:
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Horizontal - This option turns or tosses the image to horizontal position.
Vertical - This option spins or turns the image to vertical position.
* Use the Shift button to switch between the tools available under the Flip.
How to Use:
- The default flip option is set as Horizontal in toolbox.
- Simply click on any portion of the image.
- The image gets flicked horizontally.

- To do the vertical flick, select the Vertical tool option in toolbox.

- Just click on the image and it will be flicked vertically.

- User can simply toggle between the "Horizontal & Vertical" tool options, just by pressing the Ctrl
button.
- Note that you should not leave the ctrl button until you complete the flip process.
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- There is no additional tool options available with this tool.
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How to Use Path Tool

Topic

How to use path tool in GIMP?

Explanation

* It is used to create paths. Just select this option and start creating paths.
* The developed paths can be modified and can be shifted to any area in the file.
How to Launch:
- Open GIMP.
- Launch a new file.

- Shortcut for this tool is B.
- To choose this tool, click the Toolbox and then press the button B.
- Tool Options.

Design - It initiates to create the path.
Edit - The created paths can be altered i.e. any portion of the path can be modified.
Move - The entire developed path can be shifted by enabling this option.
How to Move - Create a path and click Move option in toolbox. Now, click on any portion of the path 
and move it. (View below image)
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Polygonal - Set this option to generate polygonal shape.
How to create polygonal shape - Click Design and pick Polygonal option in toolbox. Then create 
polygonal shape. (View below image)

How to use
- There are two methods through which you can create path in a file.
- The two methods are Selection from Path & Stroke Path 
Method 1:
-> Selection from Path
- It allows you to select from the currently developed path.
- Create a path and click "Selection from Path" button in toolbox.
- Then make selection from any portion of the path. (In below image, selection is made from right 
hand side of the image) 

Method 2:
-> Stroke Path
- It creates a stroke on the path created by the user.
- First, create a path and then click "Stroke Path" button in toolbox.
- Set the options in Stroke Path box and click "Stroke" button, to strike an image. (View the below 
image)
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- Finally, click "File->Save" to "Save" the file.
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How to Use Color Picker or Eye Dropper Tool

Topic

How to use color picker or eye dropper tool in GIMP?

Explanation

* The Color Picker Tool is used to select a color from any image opened on the screen.
* The color pattern available in the opened image can be picked by this tool by clicking on the 
particular color of the image.
* Both the foreground and background color can be selected by this tool.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Color picker Tool from the toolbox.

* Shortcut for this tool is O.
* To pick this tool, simply click "Tools -> Color Picker" or else click Toolbox and then press the 
button O.
Tool Options

Sample average - It activates the Radius to set whether to pick average value from pixels. The 
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radius option alters the total size of the square area.
Sample merged - Enable this option to unite all the samples. It obtains color information as 
"composite" from all visible layers.
Pick mode - The four available options helps the user to choose the mode of color pick.
The options under the Pick mode are shown as follows:
1] Pick only - The "Use info window" should be activated to enable this option. The info window 
signifies the color of the choosed pixels.
2] Set foreground color - The foreground color is applied to the selected portion of the pixels.
3] Set background color - The background color is inserted in the selected portion of the pixels.
4] Add to palette - The currently choosed color will be passed to active color palette.
Use info window - Set this option and click on the image to view the information window. It discloses 
about Pixel, RGB, HSV and CMYK.
How to Use:
- To simply pick the color, just click the "Pick only" option under "Pick Mode" in tool options in 
toolbox.
- Now click the Use info window option in toolbox or else just press "Shift" button to activate it.
- Simply drag the mouse over the image. The "Color Picker" box (Use info window) displays the 
information of the colors picked from the image. 

- To select either Foreground or Background Color just choose the Foreground color/Background 
color option in toolbox.
- Then drag the mouse over the image and pick the color. The color picker box will display the 
details of color picked, if it is enabled.
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- When Add to palette option is enabled, it picks the colors from the image and stores them into the 
Palette Editor.

- At last, click "File -> Save" to "Save" the file.
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How to Use Image Zoom In / Zoom Out Tool

Topic

How to use zoom in / zoom out tool in GIMP?

Explanation

* The Zoom Tool enables the user to magnify an image.
* The entire portion or the selected part of an image can be expanded or compressed.
* User can simply click the Plus & Minus button to maximize and minimize the image.
How to Launch:
- Open Gimp.
- Launch a new image file.

- Now pick Zoom Tool from the toolbox.

- Shortcut for this tool is Z. To select this tool, click the Toolbox and then press the button Z.

- The options available under the Zoom Tool are shown below.
Auto-resize Window - Enable this option and get the actual size of the image i.e. the image gets 
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displayed in its original size. 
Under Tool Toggle menu, there are two options were available. They are listed as below,
1] Zoom in - This option maximizes the image on each mouse click made on the image.
2] Zoom out - This option minimizes the image, every time the image is clicked.
* Use the Ctrl key to switch between "Zoom in and Zoom out" options. 
How to Use:
- To maximize an image, place the cursor on the image and click the left mouse of the buton.
- Now the image gets expanded.

- You can view the size of the image at the bottom of the image.

- Click further to maximize the image.
- To minimize an image, simply click the down arrow at the bottom of the screen and set the value.

- Now the image gets minimized. (View the below image)

- At last, click "File -> Save" to "Save" the file.
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How to Use Measure Tool

Topic

How to use image measure tool in GIMP?

Explanation

* It calculates the distance lengthwise, angle, height and width of the measured portion of the image.
* It is used to see the exact information of the measured items on the image.
* You can view the measurement information right away, when an image is measured.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Measure Tool from the toolbox.

- Shortcut for this tool is Shift + M.
Tool Options

- There is only one option available in this tool i.e. Use info window.
Use info window - It displays the measurement details,when an image is measured.
How to Use:
- Simply click the check box in toolbox to enable this option.
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- Now the drag the cursor over the image.
- The Measure box gets displayed.
- The measure box shows the measurement details like Distance, Angle, Height and Width in 
pixels. (View the below image)

- Utilize this tool to measure the image.
- Finally, click "File -> Save" to "Save" the file.
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How to Use Text Tool

Topic

How to add text to images using text editor tool in GIMP?

Explanation

* The Text Tool is used to create text on the image, which makes the image to contain texts in 
addition to the image part.
* User may be in need of placing the text on the image in different styles. For that, he/she can use 
this Text tool.
How to Launch:
- Open Gimp.
- Launch a new image file.
- Now pick Text Tool from the toolbox.

- Shortcut for this tool is T. To pick this tool manually, click the Toolbox and then press the button T.
Tool Options:

Font - Apply the desired font style for the text which you like to place.
Size - Set the height for the selected font.
Hinting - It alters the text items to generate better visible letters but in small font size.
Force auto-hinter - It automatically estimates information for better representation of the character 
fonts in a content.
Antialiasing - This option delivers a flat and even text.

Hscripts.com

Hiox.com

https://www.hscripts.com/tutorials/gimp/text-tool.html
https://hiox.com


Color - Apply different color patterns for the text.
Justify - The created texts can be justified either to Left, Right, Center  or can be Filled.
Indent - This option enables to have space and it arises from the left margin.
Line spacing - This option organizes the space between the lines of text.
Character spacing - This option enables you to manage the space between the textual characters.
Text along Path - This option inserts the text in the path.
Path from Text - This option develops the path from selected portion of the text.

- The above image shows the Text Editor, which allows you to enter the text on the image.
- There are four options available in the Text Editor and they enable you to Open a text file, Clear 
the text and Justify the text either to left or right. 
How to Use:
- Set the required tool options in the image, especially Color
- Click on any portion in the image, where you would like to create the text.
- Now the Gimp Text Editor box gets displayed.
- Then enter the text in the "Gimp Text Editor" box and the text gets displayed on the image.

- Then choose either the "Left or Right" alignment for the text.
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- To clear the text, just click the Clear option in the "Gimp Text Editor" box.

- User can even create texts from the files saved in their local computer system.
- Simply click on the Open option in the Gimp Text Editor box.

- Then Open Text File box gets displayed.
- Open the file from the location and then click "Open" button to add text to the image.
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- A sample text added image is displayed below. (View the highlighted portion in the below image)

- At last, click "File -> Save" to "Save" the file.
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How to Use GEGL (Generic Graphics Library) 

Operation

Topic

How to use GEGL (Generic Graphics Library) Operation in GIMP toolbox?

Explanation

What is GEGL?
GEGL stands for Generic Graphics Library. It is a library for image manipulation.
* The GEGL Operation enables the user to generate an image with various aspects.
* Make use of the various options listed under the GEGL to manipulate and obtain an image in 
different views.
Steps to Follow:
- Open GIMP.
- Launch any image file.
- Now you can access the GEGL Tool in two ways.
- Click Tools -> GEGL Operation or else click  Colors -> Use GEGL and click the image which you 
have opened now.

Then the GEGL OPeration box gets displayed.
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- There are around 25 options available in the GEGL Tools.

- Select any one of the options from the Operation list box; for ex:box-blur to apply the feature on 
the image.

- Then set the Radius and choose the Preview option if needed.
- Finally click the Ok Button.
- Now you will be able to see the image in a different view.
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- You can apply the remaining options in the GEGL (Generic Graphics Library) Operations to get 
different looks of an image.
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How to Select / Deselect an Image

Topic

How to select / deselect an image in GIMP?

Explanation

This page guides you as to how to select and deselect an image in GIMP.
* It helps the user to choose the entire portion or a part of an image.
Select Image:
- Start GIMP.
- Launch an image.
- Click Select -> All or simply press Ctrl+A button

- The image gets selected.

- Then you can commence your work and finally Save the file.
Deselect
If you want to unselect the marked portion, then proceed as below:
- Start GIMP and Open a file.
- Image gets displayed. You may select the entire portion or a part of an image.
- Click Select -> None or press Ctrl+Shift+A button to deselect the selected image.

- Finally click the Save Button to save the file.
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How to Invert Image Colors

Topic

How to invert image colors in GIMP?

Explanation

This tutorial guides you to invert colors in an image in GIMP.
* This option helps to develop amusing images with various color effects.
* The image will look realistic when it is manipulated with this Invert effect.
Follow the below steps to invert colors in an image:
- Start GIMP and launch a new file.
- Then select the portion of the image where you like to do the invert style.
- Click Select -> Invert or press Ctrl+I button.

- The image will be inverted now i.e. the selected portion will have a different style/color effect.(See 
the below image)

- Finally click the Save Button to save the file.
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How to Select an Image By Color

Topic

How to select an image by color in GIMP?

Explanation

* This option helps to select regions of an image through colors.
* The Select -> By Color option is an alternative method to access the Select By Color tool.
Steps to Follow:
- Open GIMP and launch a new image file.
- Pick the portion of the image using any one of the selection tools available in the toolbox. It will be 
better to use the Free Selection Tool to choose a portion of a image.

- Click Select -> By Color or press Shift+O button.

- Then click and move the mouse on the image to apply the By Color tool.

- Finally click the Save Button to save the file.
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How to Apply Border to an Image

Topic

How to apply border to an image in GIMP?

Explanation

This page explains how to apply border to an image in GIMP.
* This option places border to the selection.
* It is used to apply borders to the selected portions over an image.
Steps to Follow:
- Open GIMP.
- Start a new image file.
- Click Select -> Border.

- Then a box named Border Selection appears.
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- Enter the value of border, choose the type, set the additional options by clicking the check boxes 
and finally click the Ok button.

- The above image shows the border effect. You can note that the border is provided only for a 
particular portion of the image and not for the entire image. This option is used to place a border 
either to the entire image or a portion of an image (as given in the above image).
- Finally click the Save Button to save the file.
- Apply the existing options in the border selection to have an image with various border styles.
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How to Apply Distort to an Image

Topic

How to apply distort to an image in GIMP?

Explanation

This page explains how to distort an image in GIMP.
* The option distorts the selected portion of the image.
* Normally it twists/bends the selected outline in an image.
Steps to Follow:
- Open GIMP.
- Launch a new image file.
- Then click Select ->Distort.

- Then a box named Distort displays.
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- Set the Threshold, Spread, Granularity, Smooth options and choose horizontal, vertical smooth or 
else pick both by choosing the check boxes. Finally click the Ok button.
- The image is displayed with the Distort effect. The lines on the image will keep on be moving 
automatically.

- At the end, save the file by clicking the Save button.

Hscripts.com



How to Apply Rounded Rectangle to an Image

Topic

How to apply rounded rectangle to an image in GIMP?

Explanation

This page explains how to apply rounded rectangle to an image in GIMP.
* It helps to round/circle the corners of an image, which is chosen by the user.
Steps to Follow:
- Open GIMP.
- Start new file.
- Then click Select -> Rounded Rectangle.

- Then a box named Rounded Rectangle gets displayed.
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- Set the Radius either by entering manually or by placing the tab at the required radius percentage.
- Pick the Concave option, if you need bowl-shaped curve when the image displays.
- Then the image is displayed with the round cornered concave effect (if concave option is applied) 
where it has been selcted. (See the below image)

- At the end, save the file by clicking at the Save button.
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How to Customize Environment

Topic

How to customize environment in GIMP?

Explanation

* This option enables an user to alter and set the amount of system memory allocated for various 
purposes.
* The environment feature allows the user to cancel the confirmation dialogs, which appears during 
improper file savings.
* It permits the user to set/fix the size of thumbnail files.
Steps to Follow:
- Launch GIMP.
- Click Edit->Preferences. Then a box displays with a name Preferences with some options in it.
- The preferences box regularly displays with the Environment option at first whenever the 
preferences is opened.

- Then the options contain additional options named Resource Consumption, Image Thumbnails, 
Saving images and Document history.
- The customize environment settings help you to modify the memory levels of undo, processors 
level and set the size of the image. An additional feature permits you to halt the confirmation dialogs 
boxes which come into view when a file is closed without saving.
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- Finally click the Ok button, after setting the features.
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How to Set User Interface

Topic

How to Set User Interface in GIMP?

Explanation

* This page lets you set the layer or channel previews and keyboard shortcuts in GIMP.
* It allows an user to customize the keyboard shortcuts.
* User can reset the existing keyboard shortcuts, apply new shortcuts and save them.
Steps to Follow:
- Launch GIMP.
- Click Edit->Preferences. A box displays with a name Preferences with some options in it.
- Click the Interface option. Then user interface option gets displayed.

- It helps you to alter the layer, channel previews and the keyboard shortcuts.
- Just click on the Check Boxes in the user interface to enable or disable a feature.
- Finally click the Ok button to set user interface
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How to Change Theme

Topic

How to Change the Theme in GIMP?

Explanation

* It enables the user to select a theme which determines the appearance of GIMP.
* This feature also establishes some new features in the appearance of the GIMP on selection. For 
e.g. icons, icon size, fonts, spacing allowed in dialogs, etc.
Steps to Follow:
- Open GIMP.
- Then click Edit->Preferences.
- A box displays with a name Preferences with some options in it.
- Click one of the Themes from the options displayed.

- Two theme options are listed in the category. Click on any one of the themes in the box and view 
the change in the appearance simultaneously.
- For e.g. Click the Small option in the select theme to install it and see the transformation instantly.

- Make the changes and click Ok button to change theme.
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How to Modify Help System

Topic

How to modify help system in GIMP?

Explanation

* This option helps you to modify help system action of GIMP i.e. the functioning of the help 
feature can be altered.
Steps to Follow:
- Start GIMP.
- Click Edit->Preferences. A box displays with a name Preferences with some options in it.
- Click the Help System option in the Preferences box. Then options get displayed.

- This option makes you to revise functions of the help guide in GIMP.
-General and Help browser options are available in the help guide.
- Click the check box in the general category to show the tooltips and help buttons. Also you can 
select the options shown in the list boxes to set the user manual and browser mode.
- Finally click the Ok button.

Hscripts.com

Hiox.com

https://www.hscripts.com/tutorials/gimp/modify-help-system.html
https://hiox.com


How to Customize Tool Options

Topic

How to customize tool options in GIMP?

Explanation

* This option lets you to change the way the tools work in GIMP.
Steps to Follow:
- Open GIMP.
- Click Edit->Preferences. A box displays with a name Preferences with some options in it.
- Click the Tool Options in the Preferences box. Then options get displayed. 

- The tool options are adjusted for the better usage.
- General, Guide and Grid Snapping, Scaling, Paint Options Shared Between Tools and Move 
tool are the options provided in this customization tool.
- Customize tool options as per your needs and finally click Ok button.

Hscripts.com

Hiox.com

https://www.hscripts.com/tutorials/gimp/customize-tool-options.html
https://hiox.com


Customize Toolbox appearance

Topic

How to customize tool options in GIMP?

Explanation

* This option permits a user to modify the appearance of the Toolbox.
* The three Context Information areas in toolbox can be fixed or removed from toolbox.
Follow the below steps:
- Launch GIMP.
- Click Edit->Preferences.
- Then a box displays with a name Preferences with some options in it.
- Now click the "Toolbox" in the Preferences box.
- Appearance options appear in the toolbox.

- Click at the respective check boxes to pick the "Show Foreground & background color, Show 
active brush, pattern & gradient, Show active image" options.
- The above mentioned options will have an effect in the appearance of the color, image and pattern 
in the toolbox.
- Place the toolbox options as per your expectations and finally click Ok button.
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How to Customize Default Image Size

Topic

How to customize/change default image size in GIMP?

Explanation

* This option enables you to customize the default image size. The user can modify the default 
screen size in the "Default New Image" dialog box.
Steps to Follow:
- Open GIMP.
- Click Edit->Preferences. A box displays with a name Preferences with some options in it.
- Click the Default Image in the Preferences box. The options get displayed.
- The image size and resolutions, color, fill with options (Advanced) get displayed.

- Then set/apply your desired changes in the Image Size & Advanced Options and click the Ok 
button. You may click the "-" sign to hide the Advanced Options
- Select the Image resolution from the template list box and make the changes. Then whenever you 
open a fresh file through File->New and pick an option from the template, you will view the adjusted 
feature which you had made earlier.
- Set the default image options as per your need. Finally click Ok button.
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How to Configure Default Image Grid

Topic

How to configure default image grid in GIMP?

Explanation

* Configure Default Image Grid option enables altering the default properties of GIMP grid. This 
feature can be turned on or off using View -> Show Grid from the image menu.
Steps to Follow:
- Open GIMP.
- Click Edit->Preferences. A box displays with a name Preferences with some options in it.
- Click the Default Grid in the Preferences box or else open a file and then right click on the image. 
Select Image -> Configure.
- Appearance, Spacing and Offset options are listed.

- You can make use of this option to modify the existing properties of the grids available in GIMP.
- Set the default grid options as per your requirements. Finally click Ok button.
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How to Change Image Windows

Topic

How to change image windows in GIMP?

Explanation

* This option allows an user to change and set features related to "Mouse Pointer, Space Bar, 
Zoom and Resize effects of an image".
Steps to Follow:
- Open GIMP.
- Now click Edit->Preferences.
- Then a box displays with a name Preferences with some options in it.
- Click the Image Window option in the Preferences box and wait until the options get displayed.
- The options General, zoom, space bar & mouse pointers get displayed.

- Set the Image Window options as per your requirements.
- Finally click Ok button.
- The Image Window further includes Appearance, Title & Status options.
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- The Appearance contains two main options - "Default Appearance in Normal Mode & Full Screen 
Mode". This Appearance option enables you to change image window's default appearance - both 
for normal mode and for the fullscreen mode.
- The Title and Status shows "Image Title Format & Statusbar Format". This Title and Status 
option allows you to pick the format which appears in the title bar of an image and the status bar.
- The modification of the above mentioned tools will reflect when you launch GIMP after clicking the 
"Ok" button.
- So set the option as per your requirements and click the Ok button.
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How to Set Display Modes

Topic

How to set display modes in GIMP?

Explanation

* User can set the display modes to customize the visible/transparent portion of an image.
* Use this option to adjust the resolution of the monitor.
Steps to Follow:
- Open GIMP.
- Click Edit->Preferences.
- Then a box displays with a name Preferences with some options in it.
- Click the Display option in the Preferences box. Then the options get displayed.
-Transparency & Monitor Resolutions options get displayed.

- In "Transparency", you can set the Style and Size by selecting any one of the options in the drop 
down list box
- In the "Monitor Resolutions", you can either set Detect automatically option or else you can enter 
values manually by choosing the By Manually option.
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- Finally, click Ok button after setting the features.
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Color Management

Topic

Color Management in GIMP

Explanation

* It helps an user to modify the features of the GIMPs Color Management.
Steps to Follow:
- Launch GIMP.
- Click Edit->Preferences.
- Then a box gets displayed with a name Preferences with some options in it.
- Click the Color Management option in the Preferences box and then select a color profile from the 
menu.

- In case the expected color profile is not in the menu, you can include it by clicking on the "Select 
Color Profile" from disk item.
- Finally click Ok button after setting the features.
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How to Configure Input Devices

Topic

How to configure input devices in GIMP?

Explanation

* You can manage and control the input devices connected to your computer system by 
configuring input devices.
Steps to Follow:
- Launch GIMP.
- Click Edit->Preferences.
- Then a box gets displayed with a name Preferences with some options in it.
- Click the Input Devices option in the Preferences box. Then the options get displayed.
- "Configure Extended Input Devices" lets you to add or manipulate the devices linked to your 
computer system for .e.g. Mouse or special keyboards etc.

- Then click "Save Input Devices Settings Now" button in the box to save the current modifications.
- The input devices possess an additional option named Input Controllers. The input controllers list 
"Available and Active controllers" can be used as per your need.
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- The items inside the box can be interchanged by selecting any one of the items in the 
available/active list and then clicking the right/left arrow respectively. This tool is used to 
enable/disable an input device in GIMP.
- Finally click "Ok" button after setting the features.
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How to Configure Window Management

Topic

How to configure window management in GIMP

Explanation

* This option enables the user to customize the appearances of the windows in GIMP.
* The windows may denote the "title bar or menu bar".
Steps to Follow:
- Start GIMP.
- Click Edit->Preferences.
- Then a box gets displayed with a name "Preferences" with some options in it.
- Click the Window Management option in the Preferences box. Then the options get displayed.

- The GIMP does not control the windows directly but it passes the appeals to the window manager.
- But there is no guarantee that the options mentioned in the above "Window Management" will 
actually work. It may or may not work.
- The Window Manager Hints possess two options (For-Toolbox & Docks) with two drop down list 
boxes. 

- The normal option executes usual display and the Utility option executes different display i.e. the 
"Reduce" button would not be present. (See the above image)
- If you wish, you can enable the "Focus and Window Positions" by clicking the check boxes.
- To save the modifications, just click the "Save Windows Positions Now" button.
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- Or if you wish to reverse the current alterations, click the "Reset Saved Windows Positions to 
Default Values" button.
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Folder options

Topic

Folder options in GIMP

Explanation

* User can change and set new location/path for two main folders utilized by GIMP to store the 
temporary files.
* The two folders are Temporary Folder and Swap Folder.
Steps to Follow:
- Open GIMP.
- Click Edit->Preferences.
- Then a box gets displayed with a name "Preferences" with some options in it.
- Click the Folder option in the Preferences box.
- Then the options "Temporary Folder & Swap Folder" options get displayed with list boxes.

- Temporary Folder stores the files created for temporary purposes and it will be deleted in that 
session itself. No additional space is spent.
- Swap Folder acts as a "Memory Bank" in GIMP. In case the images, data launched in GIMP 
exceeds the RAM, then information will be stored in this folder.
- For further changes, click the "+ symbol" in the left side of the preferences box. A list gets 
displayed.
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- The options in the above image list allow you to modify the locations searched for resources for 
e.g. Brushes.
- You can also transform the folders here just by changing the entries or enter the location by 
clicking the Page icon in the above shown image.

- You can pick the particular folder options by clicking the Folder icon in the box.
- Finally click the Ok button.
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How to Create a Duplicate Image

Topic

How to create a duplicate image in GIMP?

Explanation

* The Duplicate option helps to creates a new image file of the currently launched image file in 
GIMP.
* The layers, channels and paths of the current image file will also be available in the newly opened 
file.
* The "Clipboard and Recent Opened Documents" will not be affected, if a duplicate image file was 
created.
Steps to Follow:
- Open GIMP.
- Open a new image file.
- Then click Image -> Duplicate.

- Now a duplicate file gets created. Check the below image.

- You can utilize the opened image file even when the original file exists.
- Finally save the file by clicking at the Save button.
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Convert Color Images to Black and White | 

Grayscale

Topic

How to convert color images to black and white using grayscale mode in GIMP?

Explanation

* The Grayscale option helps to convert a colour image into a black and white image.
*Helps to create images which looks like pictures taken in the past.
Steps to Follow:
- Open GIMP.
- Start an image file.
- Then click Image -> Mode -> Grayscale.

- The image turns into a gray colored picture.

- Continue the work and finally save the file by clicking the Save button.
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How to Convert Image to Indexed Color Mode

Topic

How to convert images to indexed color mode in GIMP?

Explanation

* The Indexed option helps to convert the available image into an indexed colored image.
* This tool transforms an image into an indexed color featured picture.
Steps to Follow
- Open GIMP.
- Launch an image file.
- Then click Image -> Mode -> Indexed.

- A box named Indexed Color Conversion displays.
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- Set the "Colormap and Dithering" options as per your need. For e.g. pick the Use black and white 
(1 bit)palette and click "Convert" button.

- Finally save the file by clicking the Save button.
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How to Flip An Image

Topic

How to flip an image horizontally or vertically in GIMP?

Explanation

* The Flip option enables you to turn an image either Horizontally or Vertically.
* Horizontal or Vertical conversion provides a new look/posture to an existing image.
Steps to Follow
- Start GIMP.
- Open an image file.

- Then click Image -> Transform and then choose either Flip Horizontal or Flip Vertical option.

- The image gets flipped either horizontally or vertically, depending upon the option which you have 
picked in the tranform option.
- The below image shows the horizontal and vertical flips of an image in GIMP.
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- Finally save the file by clicking at the Save button.

Hscripts.com



How to Rotate Image

Topic

How to rotate an image in GIMP?

Explanation

* Rotate image option enables you to rotate an image Clockwise, Counter-Clockwise or by 180 
degree.
Steps to Follow
- Open GIMP.
- Start an image file.

- Then click Image -> Transform and then choose any one of the three available options named 
Rotate 90 Clockwise, Rotate 90 Counter-Clockwise and Rotate 180.

- You can find the transformation or rotation of the image based on the option which you have 
selected in transform option.
- View the below images which shows the effect of the rotation option in GIMP.
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- Finally save the file by clicking at the Save button.
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How to Resize Canvas Size For Images

Topic

How to set canvas size for images in GIMP?

Explanation

*Canvas resize option allows you to alter the height,width and measurement of an image.
Steps to Follow
- Open GIMP.
- Launch an image file.
- Click Image -> Canvas Size.

- Then a box named Set Image Canvas Size gets displayed and you can view the "Preview" of the 
image in this box itself.
- Fix the "Height and Width" in the Canvas Size, choose the "Measurement" in Offset and "Resize" 
a layer in the Layers.
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- Set the Canvas Size, Offset and Layers options as per your requirements and finally click the 
Resize button.
- Check the below image with the adjusted dimensions.

- Finally save the file by clicking the Save button.
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How to Change Print Size

Topic

How to change the print resolution in GIMP?

Explanation

* Enables you to adjust/alter the Print Resolution of an image.
Steps to Follow
- Open GIMP.
- Start an image file.
- Then click Image -> Print Size.

- A box named "Set Image Print Resolution" gets displayed.

- Under the Print Size option, set the "Height, Width and Resolutions" and finally click the Ok button.
- Now you can find the image with the adjusted resolutions.
- Finally save the file by clicking the Save button.
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How to Scale An Image

Topic

How to resize the photos using scale option in GIMP?

Explanation

* Scaling option permits you to resize an image in GIMP.
Steps to Follow
- Open GIMP.
- Launch a new image file.
- Click Image -> Scale Size.

- A box named "Scale Image" gets displayed.

- Under the Scale Image, the options "Image size and Quality" are available.
- Apply the "Height, Width and Resolutions" under the Image Size category and set the type of 
"Interpolation". Set the options and finally click the "Scale" button.
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- By default, when you enter the dimension in width, the height will get adjusted proportionally. In 
order to set both the width and height dimensions manually, just split the tag by clicking over the 
highlighted portion on the above image and then adjust the dimension.
- Now the below image has been scaled.

- Finally save the file by clicking the Save button.
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How to Crop an Image

Topic

How to crop an image in GIMP?

Explanation

* This option allows the user to cut the unwanted portion from the existing image.
* Normally the tools cut only the selected portion and leaves the unselected portion untouched. But 
the Crop image option deletes the unselected part from the image.
Steps to Follow
- Open GIMP and launch an image file.
- Then select the portion which you want to crop from with available selection tool.
- Click Image -> Crop to Selection.

- The selected portion in the image gets cropped.
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- The unselected part of the image is removed by this Crop option (see the above image).
- Finally save the file by clicking the Save button.
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How To Make A Grid Effect

Topic

How to give grid effect for images in GIMP?

Explanation

* Grid Effect facilitates to frame grids as specified by the lists of X and Y locations i.e. the 
Horizontal and Vertical.
* Through this option, you can place the grid at the orientation and position as specified in Pixels for 
the image.
Steps to Follow
- Open GIMP.
- Launch a new image file.
- Click Image -> Guides.

- Select the portion of the image using any available selection tools.
- Now click New Guides from Selection from the Guides option. (View the below image)

- Then automatically the grids will be placed in all the directions - both "Horizontal and Vertical", 
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because the whole image was picked earlier.

- Finally save the file by selecting "File->Save" button.
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Set Grid With Guide Percentage

Topic

How to set grid lines with percentage in GIMP?

Explanation

* By applying grid with guide option, you can add the grid at the position specified as a percentage 
of the image size.
Follow the below steps:
- Open GIMP.
- Launch a new image file.
- Click Image -> Guides -> New Guide (by Percent).

- A box named Script-Fu:New Guide (by Percent) gets displayed with options like "Direction and 
Postion".
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- Now you can choose either horizontal or vertical in the Direction option and set the number in 
percentage in the Position.
- The grid will appear horizontally or vertically based upon the option which you have selected 
earlier.

- Finally save the file by clicking the Save button.
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How To Set Grid With Pixel

Topic

How to set grid with pixel in GIMP?

Explanation

Grid by Pixel
* This options adds grids/guides to an image.
* The position of grid is signified in the form of percentage of the canvas Height and Width.
Steps to Follow
- Open GIMP.
- Start an new image file.
- Click Image -> Guides -> New Guide.

- A box named Script-Fu:New Guide gets displayed. This box contains only two options - "Direction" 
and "Position".
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- Now set the "Direction" either horizontal/vertical and enter the value in the "Position" column.
- The grids are now placed at the positions by the pixel values which you have entered in the 
box.(Both horizontal & vertical grids are framed in the below image)

- Finally save the file by clicking "File->Save".Hscripts.com



Configure Image Grid

Topic

How to configure image grid in GIMP?

Explanation

* Allows you to arrange/organize the grids which are framed.
Steps to Follow
- Open GIMP.
- Start an image file.
- Click Image -> Configure Grid.

- A box named Configure Grid appears. This configure tool has options - "Appearance", "Spacing" 
and "Offset".
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- Set the color, line style options under the Appearance and enter the height and width in the 
Spacing and Offset.
- The grids will be set now.
- Finally save the file by clicking the Save button.Hscripts.com



Image Properties

Topic

What are the image properties in GIMP?

Explanation

* Enables you to view the entire aspects of the currently opened image in GIMP.
Step to Follow
- Open GIMP.
- Launch an image file.
- Then click Image -> Image Properties.

- A box named Image Properties appears and it exhibits the features of the image Properties menu.
-It contains menus like Properties, Color Profile and Comment.

Hscripts.com

Hiox.com

https://www.hscripts.com/tutorials/gimp/image-properties.html
https://hiox.com


- The Properties menu displays the entire properties of the currently opened image.
- User can view the properties, which are exhibited on the properties window. The properties like 
Pixel dimensions, Print size, Resolution, Color space, File name, Size, Layers, Memory and 
Pixels of an image are shown by default.

- User can view the Color Profile menu, to identify the "sRGB built-in". The sRGB built-in of the 
currently opened image is "default RGB space" of the image.(View the above image)

- User can enter his/her own remarks or statements under the Comment menu. The comment "This 
is a JPEG image" is written under the comment menu. (View the above image)
- Finally, click the Close button to close the Image Properties.
- User can utilize the Help option in the "Image Properties" menu. However, it requires internet 
connection to obtain the data from net.
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How to Remove Grid Lines From Images

Topic

How to remove grid lines from images in GIMP?

Explanation

* Remove Grid option helps to remove/eliminate the grids which were placed earlier.
Steps to Follow
- Open GIMP.
- Launch an image file.
- You may have applied the grids in any of the directions. In case you want to erase those grids just 
do as mentioned in the below steps.
- Click Image -> Guides -> Remove all Guides.

- This will remove the grids from the image (see the below image).
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- Finally save the file by clicking the Save button.
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How to Create a New Layer

Topic

How to Create/Add a New Layer in GIMP?

Explanation

* The below mentioned feature enables the user to create a new layer to the currently opened 
image.
* Add a new layer to an image by setting the measurements and its type.
Steps to Follow:
- Open GIMP.
- Launch a new image file.
- Click Layer -> New Layer or press Shift+Ctrl+N to create a new layer in an image.

- The New Layer window opens.

- Enter the name, adjust the height and width properties, finally set the type by choosing any one of 
the available four options and click the Ok button.
- The Layer Fill Type menu consists of options which determines the colour of the layer which is to 
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be displayed in the image. (View the below image)

- In the above image, the newly added layer is completely covered with white color as the 
Foreground Color is set as White color.
- Finally save the file by clicking File->Save.
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How to Resize a Layer Boundary

Topic

How to resize/change a layer boundary in GIMP?

Explanation

* The dimensions of the inserted layers can be modified by changing the layer boundary size.
Steps to Follow:
- Open GIMP.
- Launch an image file.
- Click Layer -> Layer Boundary Size.

- A box named Set Layer Boundary Size gets displayed.
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- You can see the "Preview" of the image below the Offset option.
- Apply the Layer Size and Offset options available in the Set Layer Boundary Size box and click 
the Resize button.
- Get the image with the changed boundary layer. (View the below image)

- Finally save the file by clicking the Save button.
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How to Adjust a Layer to Image Size

Topic

How to adjust a layer to image size in GIMP?

Explanation

* The below mentioned feature enables the user to adjust a layer to image size.
Steps to Follow:
- Launch GIMP.
- Open a new image file.
- After adding a new layer, you can resize the boundary through Layer Boundary Size option.
- If you want to resize the layer according to image size then click Layer -> Layer to Image Size.

- Now the layer gets resized according to the image in the below picture.

- Finally save the file by clicking the Save button.
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How to Autocrop A Layer

Topic

How to autocrop a layer in GIMP?

Explanation

* The autocrop option allows the user to cut or clip the layer inserted in the image automatically.
Steps to Follow
- Start GIMP.
- Open an image file.

- Layers can be inserted to an image by choosing Layer -> New Layer.

- To remove it, click the Layer -> Autocrop Layer.
- The layer on the image gets cropped automatically on its own. (View the below image)
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- Finally save the file by clicking the Save button.
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How to Scale a Layer

Topic

How to scale/resize a layer in GIMP?

Explanation

* This option helps to resize a layer content.
Follow the below steps:
- Open GIMP.
- Launch a new image file.

- Layers can be included in an image by selecting the image and clicking the  Layer -> New Layer.
- To scale a layer, Click Layer-> Scale Layer.

- A box gets displayed with the name Scale Layer along with the options relating to its size and 
Quality.
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- Now make the adjustments in the "Height and Width" options in the Layer Size and select one of 
the interpolation options available from the Quality.
- Look at the below image for which the layer resizing has been done.

- Finally save the file by clicking the "File->Save".Hscripts.com



How to Change the Colors

Topic

How to change/replace the colors in GIMP?

Explanation

* This option allows the user to  replace the colors of an image with the specified shades.
Steps to Follow:
- Start GIMP.
- Launch a new image file.

- To select a whole image, just press Ctrl+A.
- If needed, the user can pick a portion of an image and apply this option to view the color effect.
- Now click Colors -> Colorify.

- Then a box gets displayed with three different options namely, Preview, Zoom and Custom color.
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- Set the Preview option to view the image while applying changes. It is also used to maximize and 
minimize the image.
- The above image shows the preview along with Zoom option to enlarge/minimize the picture. 
- There are seven Custom colors available in the "Colorify" toolbox.
- Choose any one of the colors to replace the existing color of an image for e.g. Green Color.
- Finally click the Ok button.
- Now view the below image replaced by Green Color.

- At last, click File->Save button to save the file.

Hscripts.com



How to Convert Color to Alpha

Topic

How to convert color to alpha in GIMP?

Explanation

* The Color to Alpha option makes the entire pixels of the current layer to be crystal clear and to 
have a selected color.
* The Alpha channel is created by this option.
Steps to Follow
- Start GIMP.
- Open an image file.

- Then select the image by pressing Ctrl+A or Select -> All.
- Click Colors -> Color to Alpha.

- A box displays with a name Color to Alpha.
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- The "Preview" option is used to view the preview of the currently opened image. You can also 
select a color in the "From - to alpha" to see the effect of it in the preview.
- Click the Preview check box to view the image, pick a color from the "From" option and finally click 
the Ok button.

- Save the file by clicking the Save button.

Hscripts.com



How to Fix the Pixelated Image

Topic

How to fix the pixelated image in GIMP?

Explanation

* This option helps to identify the pixels which are unnecessarily being too bright and to place them 
in the correct position.
Follow the below steps:
- Start GIMP.
- Open an image file.
- Then select the entire picture in order to fix the pixels in the image, by pressing Ctrl+A or Select -> 
All.
- Click Colors -> Hot.

- Then a box displays with the name Hot. This box contains options like Mode, Action and Create 
new layer.
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- Set the Mode, select any one of the options from the "Action" to decrease luminance or saturation 
or blacken, select a new layer if you need. Finally click the Ok button to fix the pixalated image.
- Now the pixels in the image is sticked together.(View the below image)

- At the end, save the file by clicking the Save button.
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How To Modify/Change Image Color

Topic

How to modify / change image color in GIMP?

Explanation

* This modify image color allows the user to alter the colors of the currently opened image in an 
interactive manner.
* It is necessary to apply "Maximum RGB" feature to an image before applying this "Hot" option to 
change colors.
Steps to Follow:
- Start GIMP.
- Launch a new image file.

- To select the entire image, click Select -> All or else press Ctrl+A.
- Click Colors -> Maximum RGB.
- Then a box named Maximum RGB Value appears.
- Set the options and click "Ok" button.
- Now the image is set to "RGB" mode. (View the below image)

- Now click the Colors -> Hot.
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- A box named Hot gets displayed.

- Set the features in options "Mode and Action".
- If necessary, the user can select the "Create New Layer" option in the box.
- Finally click the "Ok" button and view the image.

- At last, click File -> Save to save the file.
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How to Use Filter Pack

Topic

How to Use Filter Pack in GIMP?

Explanation

* Filter Pack option allows the user to alter the colors of the currently opened image in an 
interactive manner.
Steps to Follow:
- Start GIMP.
- Open a new image file.
- Then select the entire image either by clicking Select -> All or press Ctrl+A.
- Click Colors -> Filter Pack.

- Then a box displays named as Filter Pack Stimulation.
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- Set the features in five major menus in the "Filter Pack stimulation" box.
- Choose the image selection under the Show menu, set the display in the Affected Range menu, 
pixels in the Select Pixels By menu, clarity in the Windows menu and set the Roughness.
- Finally click the Ok button.
- The below displayed image is the outcome of the options set in the "Filter Pack Stimulation" box.

- Finally save the file by clicking the File -> Save button.
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How to Enhance Image Using Retinex Tool

Topic

How to enhance image using retinex tools in GIMP?

Explanation

* This option helps to enhance the contrast of the image using the tool Retinex.
Steps to Follow:
- Start GIMP.
- Open an image file.

- Select the entire image either by clicking Select -> All or press Ctrl+A.
- Click Colors -> Retinex.

- Then a box named Retinex Image Enhancement gets displayed. Select the Preview option in the 
box and view the existing image. Also use the Zoom option to maximize the image.
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- Set the Level as Uniform or Low or High. Adjust the measurements in the Scale, Scale division, 
Dynamic and see the preview of the image. If you are satisfied, then click the Ok button.

- Finally save the file by clicking the Save button.
-The contrast of an image has been increased by the use of retinex tool.
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How to Convert an Image to RGB Color Mode

Topic

How to convert an image to RGB color mode in GIMP?

Explanation

* This option has the ability to apply multiple colors to an image.
* The colors Red, Green and Blue are added to an image when this tool is used.
Steps to Follow:
- Start GIMP.
- Launch a new image file.

- Select the entire image by just by clicking Select -> All or press Ctrl+A.
- Click Colors -> Maximum RGB.

- A box with a name Maximum RGB Value gets displayed.
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- Initially click the "Preview" check box to view the image simultaneously while applying the changes.
- Now, choose either "Hold the maximal channels" or "Hold the minimal channels" option to have 
bright or dim effect on the image and finally click the Ok button.
- The changes applied to the picture gives a different look to the image.
- Now the image is changed to RGB color mode.

- Finally save the file by clicking the "File->Save" button.
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How to Open Recently Closed Docks

Topic

How to open recently closed docks in GIMP?

Explanation

* This tool helps to launch the docks which were closed by the user recently.
Steps to Follow:
- Launch GIMP.
- Click Windows -> Recently Closed Docks -> Layers, Channels, Paths, Undo - Brush..

- A box gets displayed with a name Layers, Channels, Paths, Undo - Brushes, Patterns, Gradients. 
The layers is displayed first.

- Click the available tabs next to Layers i.e. Channels, Paths and Undo History, to view and set the 
features. The below images exhibit the remaining tabs in this box.
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- Make the alterations and finally save the file.
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How to Magnify Image

Topic

How to magnify an image in GIMP?

Explanation

* This option allows the user to maximize and minimize an image.
* It is not necessary to use any tools in the Toolbox or Menu for maximizing and minimizing 
purposes.
* It can also be referred as "Zoom Tool".
Steps to follow
-> Open GIMP.
-> Launch an new image file.

-> Find the size of the currently opened image at the bottom of the screen. 

-> To enlarge the image, click the down arrow. Select any one of the available seven values. Ex: 
200%.
-> Now the image has been expanded. View the below image.
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-> You can also choose the lower values to minimize the image. for e.g. 50% or 25% or 12.5%.

-> You can even enter the manual values. Just click inside the box and type value of your choice.
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How to Shrink and Grow Image

Topic

How to shrink and grow images in GIMP?

Explanation

* Shrink option minimizes the size of the selected portion in an image.
* It moves the points on the edge of the selection to a certain distance.
* Grow option maximizes the choosed portion in an image.
* Either the selected portion or the whole image can be maximized.
How to launch:
- Open GIMP and launch an image file.
- Select the portion of an image, using any one available selection tools. 
- Click Select -> Shrink.

- A box named Shrink Selection displays.
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- Apply the values in the above box to shrink an image.
Grow an image:
* Grow option allows you to maximize the selection.
- Click Select -> Grow.
- A box named Grow Selection appears.

- Set the values in the above box as per your requirements to grow an image.
- To gather more information regarding "Shrink and grow", just click the "Next" button.Hscripts.com



How to Shrink an Image

Topic

How to shrink images in GIMP?

Explanation

* Shrink Image option minimizes the size of the selected portion in an image.
* It moves the points on the edge of the selection to a certain distance.
How to Launch:
- Open GIMP.
- Launch a new image file.
- Now select a portion of an image.
- Then, click Select -> Shrink.

- A box named Shrink Selection displays.
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- Just set the value, choose the type in the mode i.e. pixels or millimeters, in which you want to 
shrink an image.
- Set the option "Shrink from image border" if you want the image to be shrunken from the border.
- Finally click Ok button.
- Now the selected portion in the image gets shrunk.

- The marked portion in the above is the shrunken part.
- Finally save the file by clicking "File->Save" button.
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How to Grow an Image

Topic

How to grow images in GIMP?

Explanation

* Grow Image option maximizes the chosen portion of an image.
* Either the selected portion or the whole image can be maximized.
How to Launch
- Open GIMP.
- Launch a new image file.
- Pick a portion of the image using selection tool.
- Then click Select -> Grow.

- A box named Grow Selection appears.
- Enter the value and set the mode i.e. Pixels, inches, millimeters, points; to grow the image.
- Finally, click Ok button.
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- Now the selected portion of the image gets expanded.

- Finally save the file by clicking "File->Save" button.
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How to Configure Tab in Toolbox

Topic

How to configure toolbox in GIMP?

Explanation

In GIMP, the user can adjust the toolbox as per his/her requirements. Just click the left arrow icon in 
toolbox to configure the toolbox.
* Steps to Follow:
-> Open GIMP.
-> Launch an image file.
-> Now, click the left arrow in the tool box.

-> The list of available menu gets displayed. Some of the options would have been selected by 
default.
-> The Tool Options Menu allows you to organize the four options present in the toolbox namely - 
save, restore, rename and delete.

Click the Add Tab option. A list of options gets displayed. Select any one - for ex: Histogram. The 
Histogram is placed above the toolbox.
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-> If the option Lock Tab to Dock is enabled, you will not be able to pull/move the tool option from 
the Toolbox.
-> The Show Image Selection option displays the file name/information of the currently opened 
image.

-> You can also "Close & Detach" the tab from toolbox.
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